Input setting not persistent across sessions

Forums / NoMachine for Linux / Input setting not persistent across sessions

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #9438
    qti_perryman
    Participant

    I use !Machine in two contexts … one from a locked down thin client running Linux, and one from within a remote desktop windows session on the same thin client.  They both access the same host.

    freerdp 1.1.0-hp5.16

    Windows 7 Enterprise

    NX version 4.6.16

    Server OS Linux

    SUSE Linux Enterprise Desktop 11 (x86_64)

    Version = 11

    PATCHLEVEL = 3

    Thin Client info

    HPT520

    Build T6X50034 – ThinPro 1GB i386 5.0.0.0 build 34

    OS Kernel Version   3.8.13-hp

    NX 4.6.16

    I dislike the hot keys and have disabled them (or so I thought) in both client settings.   During the session that I disable the hot keys, the software works as expected.  However, if I close my session and open it in the other context, the hot keys are still active (ie. doing what !Machine defines and not passing them through to my session)  I then have to go to the settings, and re-enable the hot keys, then disable them, and then for the remainder of the time the hot keys are passed through.

    Interestingly, when I go to the settings window, the settings are “stored” correctly and they are displayed as “disabled” (ie. unchecked), however until I enable and disable them, the underlying software operates as if they are “enabled”

    This kind of defeats the purpose of the settings.

    Is there a diagnostic facility for keyboard mapping issues in NX?

    I have also found that some keys are not being passed through to the X window system correctly.  I used “xev” in a session and found that my delete key was not being sent properly to the X applications.  The key works as expected on the thin client and in the windows remote desktop running on the thin client, but both the !M clients were not passing the delete key presses  through to the X11 applications running in the session.

    Thanks for any help.

     

    Ian

     

     

    #9451
    graywolf
    Moderator

    Hello.

    NoMachine 5.0.53 introduced many changes. Is it possible for you trying the latest NoMachine client?

    #9667
    qti_perryman
    Participant

    Thanks for the reply.  I am not in control of which client we are using unfortunately.  The IT Department controls that.

    Does anyone from  !Machine monitor these forums?

    Ian

     

     

    #9776
    qti_perryman
    Participant

    Confirming issue is fixed in Player 5.0.63 with Server 4.6.16

    Thanks,

    Also delete key issue was related to Gnome settings.  I cleaned out my old Gnome settings, restarted my desktop and then it started to work.

    Ian

    #9783
    Britgirl
    Keymaster

    Thanks for notifying Graywolf, one of our developers, that updating the client fixed the issue.

    As a P.S, if you’re connecting to a NoMachine server which is covered by technical assistance, your administrator can always open a ticket via the official support channel and get a reply within the response time provided by the subscription. This is what I recommend you do if you have further issues when using the latest Player with the server version being deployed at your organization.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.