Installation of the NoMachine USB Adaptor Failed Error Code 183

Forums / NoMachine for Windows / Installation of the NoMachine USB Adaptor Failed Error Code 183

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #16112
    Avatarmatt16
    Participant

    NoMachine: Free
    Version: 5.3.12
    Platform: Windows 8

    I installed/uninstalled NoMachine successfully. When I try to install it again I get this message: “Installation of the NoMachine USB Adapter has failed with error code: 183.”

    If I ignore this message I can successfully use NoMachine to connect to another computer but my USB device list is empty.

    USB devices are being shared in preferences: https://www.screencast.com/t/CGHK5sld

    I followed these instructions to enable USB device sharing manually:  https://www.nomachine.com/DT09L00071

    There’s another post that mentions this same error: https://www.nomachine.com/forums/topic/error-installing-usb-devices-error-code-183

    I’ve tried all sorts of things to resolve including multiple installs/uninstalls, PC restarts, etc.

    I tried to manually uninstall NoMachine USB devices (but the instructions here are outdated): https://nomachine.com/AR10K00732

    I see NoMachine USB Host Adapter in device manager: https://www.screencast.com/t/PpdJlivAWIBN

    Any help greatly appreciated to get USB device sharing working correctly.

    #16141
    AvatarDawid.G
    Participant

    Hello,

    This issue is probably related with registering filters in registry. To resolve this I would suggest to follow those steps:

    1. Uninstall NoMachine

    2. Reboot the machine

    3. Check if “NoMachine USB Host Adapter” appears in device manager. If so, uninstall it.

    4. Unregister “NoMachine USB Hub Filter”. To do that, you need to:

    a) Open Windows registry: Menu start -> run -> regedit

    b) Find the following registry key in the tree on the left:

    “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36fc9e60-c465-11cf-8056-444553540000}”

    c) Find UPPERFILTERS variable on the right side.

    Note: it should contain list of registered filters, but maybe it’s empty if no filter is registered.

    Edit UPPERFILTERS variable and remove entries containing nx prefix (e.g. “nxusbf”) if they exist.

    5. Reboot the machine

    6. Install NoMachine

     

    I hope this will help you.

    Regards.

    #16166
    Avatarmatt16
    Participant

    Thank you! I was able to successfully uninstall and re-install NoMachine based on these instructions.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.