Invalid RT packet size

Forums / NoMachine for Windows / Invalid RT packet size

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #12085
    Stigmj
    Participant

    I’m using 5.1.44 server (free version) on a Win8.1 laptop and 5.1.44 client (free version) on a Ubuntu 16.04 desktop (standard Unity7.4). The Win8.1 5.1.44 server was recently updated, but so was my Ubuntu desktop from 14.04 to 16.04.1. Not sure which upgrade resulted in this error, but when I try to connect to the Windows-machine (physical display, on the same LAN), it fails with the following logs (the “249 read” changes):

    22889 23334 06:39:22 040,074 ProxyRealtime/Realtime: ERROR! Invalid RT packet size 1440 with 249 read.
    Error: Invalid RT packet size 1440 with 249 read.
    22889 23334 06:39:22 040,125 ProxyRealtime/Threadable: WARNING! Aborting threadable 0x7fbac801a290.
    22889 23334 06:39:22 040,142 ProxyRealtime/Threadable: WARNING! Error is 22, ‘Invalid argument’.
    22889 23334 06:39:22 040,149 ProxyRealtime/Threadable: WARNING! Threadable 0x7fbac801a290 aborted.
    22889 23334 06:39:22 040,155 ProxyRealtime/Threadable: WARNING! Setting error in threadable 0x7fbac801a290.

    22889 23334 06:39:22 040,161 ProxyRealtime/Threadable: WARNING! Restoring context from threadable 0x7fbac801a290.
    22889 23329 06:39:22 040,252 ProxySession/ProxySession: WARNING! Handling failed RT handler.
    Session: Session terminated at Mon Aug 15 06:39:22 2016.
    22889 22889 06:39:22 043,021 ClientSession: Destroying the view at 0x2013390 with frame id 0x7fbaf82235d0.
    Info: Session window surface removed.
    22889 22889 06:39:22 086,237 ClientSession: Exiting from the client transport loop.
    22889 22889 06:39:22 086,258 ClientSession: The transport closed with reset ‘1’ error ’22’.
    22889 22889 06:39:22 086,309 ClientSession: Session at 0x1bfbe90 failed.
    22889 22889 06:39:22 086,330 ClientSession: Failing reason is ‘The connection with the server was lost.
    Error is 22: Invalid argument.’.
    22889 22889 06:39:22 088,232 ClientSession: Stopping session at 0x1bfbe90.

    Any clues on what to do?

    #12098
    Britgirl
    Keymaster

    Hi, try disabling UDP as a temporary workaround. Do that via the GUI: choose the connection -> Edit -> Advanced -> uncheck ‘use UDP communication for multimedia data’.

    So far we’ve not been able to reproduce the issue. Would you be interested in installing a debug version to help with our investigation?

    #12116
    Stigmj
    Participant

    Disabling UDP did in fact work. I have verified by

    1. disabling UDP
    2. connecting OK
    3. restarting the windows “server”, to be sure.
    4. connecting OK
    5. enabling UDP again
    6. connected with the same error as before.

    I’m willing to help investigating this issue by using a debug version.

    #12179
    Britgirl
    Keymaster

    Additional note from the user about the debug version sent.

    “I removed the standard versions and then installed the debug-versions as supplied on both server and client, and the problem was gone.

    * I reinstalled a 5.1.44-1 version downloaded from http://www.nomachine.com on the client, and the problem was not apparent anymore
    * I then reinstalled a 5.1.44-1 version downloaded from http://www.nomachine.com on the server as well, and the problem was not apparent anymore”
Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.