iPad OS 14 gives me “No route to host” error

Forums / NoMachine for Mobile / iPad OS 14 gives me “No route to host” error

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29863
    Avatarjim
    Participant

    Since upgrading my iPad (7th generation) to iPad OS 14.0.1 I can no longer use the NoMachine to control Windows 10 computers (which are on the same network as my iPad).  The error I receive is

    “Could not connect to the server.  Error is 65: No route to host”

    I’m not aware of any other changes other than my iPad upgrade from iPad OS 13 to 14.  From the Windows 10 desktops I can still ping my iPad, so the “no route to host” error seemed to be a red herring.

    Has anyone else seen this behavior?  Any ideas on how to fix this?

    #29907
    AvatarBritgirl
    Keymaster

    You should see a message asking to find and connect to other computers on the network (see attached). Click OK.

    Do you not see this message?

    Attachments:
    #29909
    Avatarjim
    Participant

    That showed the first time running NoMachine after my iPad updated, I may have tapped “Don’t Allow”.   I don’t know how to get that message back, but I do have the NoMachine app’s privacy setting “Network browsing” setting “Don’t show other computers on the network” set to off.  Is that the same thing?  If not, how do I allow the app to connect to computers on my network?

    #29911
    AvatarBritgirl
    Keymaster

    It seems like a new privacy/security check by iOS. Even if you have set “Network browsing” to show NoMachine computers on the network, you will now need to grant permissions explicitly in iOS.

    Open Settings, Privacy, Local Network, look for the NoMachine app in the list and grant the permission.

    Does this help?

    #29913
    Avatarjim
    Participant

    Open Settings, Privacy, Local Network, look for the NoMachine app in the list and grant the permission.

    Yes, that was it!  Setting “Privacy, Local Network” to on for NoMachine is all that’s required for this to work.  I.e. with “Network browsing” set to off in NoMachine’s settings that just disables the auto-discovery of NoMachine servers.  All of my statically defined connections continue to work.

    I thought there might be an Apple setting affecting this, but when you search the settings app for “NoMachine” you don’t get any results.

    Thanks for much for the quick fix.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.