Issue with limit of NoMachine Guest sessions

Forums / NoMachine Terminal Server Products / Issue with limit of NoMachine Guest sessions

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #21461
    helfgott
    Participant

    Hi everyone,

     

    I’m trying to expand the number of guest sessions available by using the directive GuestUserLimit

    #

    # Set the maximum number of concurrent NX guest users

    #

    GuestUserLimit 1500 # helfgott added

     

    Anyway after changing the value to 1500, 100 or whatever after 10 connections I’m not able to create more sessions. Funny thing if you set it to ‘2’ only can create 2 sessions.

    Is there maybe a limit for that parameter?

     

    2019-02-15 17:32:53 153.051 118102 NXSERVER User ‘guest0108’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:33:00 151.192 118190 NXSERVER User ‘guest0109’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:33:07 176.636 118276 NXSERVER User ‘guest0110’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:33:14 164.373 118353 NXSERVER User ‘guest0111’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:33:21 163.810 118427 NXSERVER User ‘guest0112’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:33:28 267.656 118501 NXSERVER User ‘guest0113’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:33:30 614.237 118353 NXSERVER ERROR! Received error message from node ‘PSNOMACHINENODEVEN1:4000’, ‘NX> 595 Cannot add user ‘guest0111’ to system: ‘

    2019-02-15 17:33:30 616.987 118353 NXSERVER WARNING! Cannot set session on node: PSNOMACHINENODEVEN1:4000.

    2019-02-15 17:33:30 730.921 118353 NXSERVER WARNING! Cannot write to FD#12.

    2019-02-15 17:33:30 731.114 118353 NXSERVER WARNING! Error is: 32, ‘Broken pipe’.

    2019-02-15 17:33:30 731.380 118353 NXSERVER WARNING! Cannot send logout to the remote node.

    2019-02-15 17:33:35 374.325 118587 NXSERVER User ‘guest0114’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:33:42 275.071 118661 NXSERVER User ‘guest0115’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:33:49 256.899 118752 NXSERVER User ‘guest0107’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:33:56 258.187 118840 NXSERVER User ‘guest0116’ logged in from ‘76.252.78.188’ using authentication method NX-password.

    2019-02-15 17:34:03 195.807 118928 NXSERVER ERROR! Authentication with ‘NX-password’ from host ‘76.252.78.188’ failed. Error is ‘Cannot assign guest account Reached the maximum number of concurrent guest users on this server.’.

    2019-02-15 17:34:10 191.272 118994 NXSERVER ERROR! Authentication with ‘NX-password’ from host ‘76.252.78.188’ failed. Error is ‘Cannot assign guest account Reached the maximum number of concurrent guest users on this server.’.

     

    #21493
    Gega
    Participant

    Hello helfgott,

    Comments aren’t supported on the same line of enabled key – value. So please try to remove < # helfgott added> and leave plain <GuestUserLimit 1500>  to get expected behavior.

    #21509
    helfgott
    Participant

    @Gega thank you, confirmed that custom comments affect the behavior of the product.

    Removing the custom comment worked.

    Thanks.

    H.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.