Keep session alive after logout

Forums / General Discussions / Keep session alive after logout

This topic contains 4 replies, has 2 voices, and was last updated by Avatar ntms 1 month, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #22781
    Avatar
    ntms
    Participant

    Hi,

    If I logout from my remote Ubuntu machine, I am not able to login again. So I need to always make my remote machine to stay in login mode. How can I start remote ubuntu NoMachine server after logout or restart?

    #22791
    Avatar
    Mth
    Contributor

    Hello.

    There could be a few things that can be at fault here.

    1. Is the remote machine headless? Are you connecting to actual physical session?
    If there is a problem with detecting physical session, the NoMachine will create a virtual one
    to connect, and logging out would cause the session to shut down.

    2. If there is actual physical session, please check if the Login Window is running Xserver
    or Wayland. If it is Wayland, please try to disable it and see if that helps.

    3. There is a rare case when Login Window is wrongly identified as running as different user.
    Please check if after connecting to the server the view is set on “All desktops” instead of
    “My desktops”

    If this does not help, please provide us with logs.

    Article on how to collect logs:

    https://www.nomachine.com/DT10O00163 (“How to gather debug logs for support requests”)

    After gathering logs, please send them to forum[at]nomachine[dot]com using the title of that forum’s
    thread as the mail’s subject.

    /Mth

    #22802
    Avatar
    ntms
    Participant

    Thanks,

    1) Yes it is headless. Ubuntu 18.04.02 created onVMware vSphere.

    2) didn’t show Wayland. I use “echo $XDG_SESSION_TYPE” command and showed as: x11

    3) I will send the log files as described above.

     

    Steps:

    I connect to server and logged in. If I try to restart client machine with same logged in session; next login I get a white screen. I have to go to remote place (where is my VMware vSphere reside) and use VMware vSphere consle to login to machine. I come back and use NoMachine.  This time shows white screen and pressing Enter key I can enter the remote machine.

    #22804
    Avatar
    Mth
    Contributor

    Hello.

    Thank you for the logs.

    It seems that, while not on user desktop which uses Xorg, the gdm login manager is using Wayland. Unfortunately our video grabbing method for Wayland does not work on virtual machines yet.

    Right now the only way for NoMachine to work properly is to disable Wayland on login window screen. For Ubuntu and gdm this would be editing /etc/gdm3/custom.conf file and adding or

    uncommenting the line:

    WaylandEnable=false

    /Mth

    #22824
    Avatar
    ntms
    Participant

    Thanks @mth, yes it worked. I connect to remote machine apply the part that you wrote and restart the remote machine. The white screen was only 3 seconds and then login screen comes up. I enter my credentials and it looks like freezed about 5 seconds and I enter the machine. Small glitch but I can live with it. Thanks.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.