Keyboard lag when entering text

Forums / NoMachine for Linux / Keyboard lag when entering text

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #25115
    Avatarmichael james
    Participant

    Hi,

    I’m currently evaluating using NoMachine to enable our Windows 10 laptops to access a Linux GNOME VM environment, and I’m finding a small but irritating delay between keyboard/mouse input and selection, and the display.

    Are there any tweaks I can apply to make it more usable?

    Thanks

    #25128
    Avatargraywolf
    Moderator

    Is direct rendering On in the virtual desktop? Please verify with command glxinfo | grep -i render.

    #25129
    Avatarmichael james
    Participant

    yes it is,

    bash-4.2$ glxinfo | grep -i rendering

    direct rendering: Yes

    is this good or bad??

    #25139
    Avatargraywolf
    Moderator

    It is good. What about “renderer” in the output from glxinfo (glxinfo | grep -i renderer)? Please be sure you issue the command remotely through NoMachine.

    How are DISPLAY vars set? Please run env | grep DISP

    Would you verify the kind of NoMachine session? With NoMachine connected to the remote host, press combo Ctrl+Alt+0 and chose Connection information; look at “session type”.

    If the type is “virtual desktop” you can try to turn off X11VectorGraphics; in node.cfg, place: AgentX11VectorGraphics 0. See also this (applies only to virtual desktop session type): https://www.nomachine.com/AR02L00779

    #25153
    Avatarmichael james
    Participant

    Hi,

    Thanks for the response. Below is the more noisy output from glxinfo:-

    nx-host$ glxinfo | grep -i render

    direct rendering: Yes

    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,

    GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer,

    Extended renderer info (GLX_MESA_query_renderer):

    OpenGL renderer string: llvmpipe (LLVM 7.0, 256 bits)

    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,

    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fog_distance,

    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

    DISPLAY is set to this:-

    nx-host$ env|grep DISP

    DISPLAY=:0

    The session type is “physical server” but how would I change this to virtual? Is this available in the free version?

    #25210
    Avatargraywolf
    Moderator

    Physical is OK: AgentX11VectorGraphics 0 is implicit in that case. Switching to “virtual” would not provide any leverage. If you want to try it anyway, just turn off Gdm display manager (systemctl stop display-manager): on the next try NoMachine will ask you if you want to create a virtual display server.

    In my opinion, VM has not support for video acceleration (OpenGL renderer is llvmpipe, that is CPU renderer) so you get poor gnome performance. Would you consider a more lightweight desktop like Xfce? Otherwise you could try providing more CPU power to the VM in order to get a faster rendering by llvmpipe.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.