Keyboard language

Forums / NoMachine for Linux / Keyboard language

Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #10031
    jerome_
    Participant

    Hi, my keyboards (serveur and client sides) are in French azerty, but on NoMachine, only qxerty English keyboard. I not find configuration part for tell them to use correct keyboard configuration.

    i’m on archlinux server and client side.

    Any help please ?

    #10048
    graywolf
    Moderator

    Hello. There is no configuration for keyboard layout, NoMachine gets information about the current keyboard from the client system.

    If you are using the most recent version of NoMachine (5.0.63) on client and server it is likely you just need to set the keyboard layout in the remote session. Just run NoMachine, connect to remote session, search for Keyboard configuration (it is located depending on desktop environment in use) and set the French layout. Be sure French is set in the desktop at client side too.

    If that isn’t the case, please let me know  NoMachine product and version on local and remote machine and whether the problem arises connecting to a physical or a virtual display.

     

    #10053
    fraannk
    Participant

    I’m having a couple of problems as well. When I connect with my Danish Mac to my Xubuntu server, and I want to type “æøå”, other symbols appear instead.

    When I connect from my iOS device the same problem persists, and if I connect a bluetooth keyboard to the iOS device, the right “alt” or “option” button doesn’t work as an “AltGr” button as it should.

    Any suggestions?

    #10059
    graywolf
    Moderator

    fraannk,

    please specify whether you are connecting to the Xubuntu physical display.

    It is likely you have to set the keyboard to Danish in the Xubuntu remote session.

    About the AltGr issue, I don’t know if it specific to iOS, but it looks related to wrong keyboard layout as well (many keyboard layouts – US for example –  has no AltGr key).

     

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.