Keyboard layout does not match my physical keyboard

Forums / NoMachine for Windows / Keyboard layout does not match my physical keyboard

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #31552
    hweisen
    Participant

    Hello, the most annoying feature of NoMachine (on Windows 10) is that, while I normally use the Swiss-French keyboard, NoMachine finds itself most of the time in the UK or US (don’t know) keyboards. It recently, to my delight and without any conscious input from me, jumped spontaneously to the Swiss French one! It wasn’t to last however, as today I struggling again with a keyboard that I’m not used to. Forums and blogs seem to suggest that the virtual keyboard needs to match the physical one. After half an hour of searching around in the menus I have found no way of getting to anything like a virtual keyboard or anything useful about keyboard settings, certainly not in the ‘Input’ panel under ‘keyboard and mouse’ nor inder ‘preferences’ .

    I can’t find anything telling me what version of NoMachine this is, but the oldest installation files on the bin folder are 25.9.2020.

    Thanks for any help.

    #31578
    graywolf
    Moderator

    Hello. The keyboard layout of the client is irrelevant. You need to take care of the keyboard layout on the remote server host. NoMachine forwards keyboard events as “raw keys” (physical key codes, the symbol impressed on the keys don’t matter), so the remote server layout is the one that really matters. NoMachine does not provide any tool for changing keyboard layout as you can use the remote host system settings to change it accordingly to your needs.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.