Keyboard mapping problem (bis)

Forums / NoMachine for Linux / Keyboard mapping problem (bis)

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #673
    mt
    Participant

    Hello,

    I tough the problem (reported earlier) was solved but in fact it is not.
    I get the english keyboard mapping with french keyboard. Here are my parameters:
    Opensuse 12.3 on client and server.
    Enlish OS with french keyboard layout on both client and server.
    Nomachine Linux free version (no virtual desktop)
    Nomachine server 4.0.362 with player 4.0.360.

    At first the problem was solved but it is not. It reproduces every time I connect to the server after server reboot or login/logout.
    The only thing that solves the problem temporarily is to change the keyboard layout on the server side using yast.

    Hope to have provided all necessary info to allow you to reproduce the problem.

    Michal

    #683
    Britgirl
    Keymaster

    Hello Michal, please check this article: https://www.nomachine.com/AR11K00740

    You can try putting the following in the .profile of the user, to force the setting, or find a way to let Yast automatically apply your setting when you login.

    setxkbmap -rules evdev -layout fr

    Note that this appears to be a Yast bug. I don’t see any reason why it should “forget” about your setting once you have set the keyboard in Yast,

    #693
    titan
    Participant

    Dear Michal,

    bear in mind that we are NOT going add “setxkbmap -rules evdev -layout ” to the user’s profile 😉 . We cannot incur in the risk of breaking things in a perfectly working environment just to solve a YAST, or some other Linux or Desktop Environment’s bug. There were a few selected cases we tried doing that in version 3, exactly to solve tricky keyboard problems, making things worse and confusing for some of the users. NX 4 is a clean-room implementation clearing the ground from all such workarounds (or at least ought to be).

    #707
    mt
    Participant

    Thanks for the answer.
    The workaround is a perfectly valid solution for me.
    It is just not really clear at first sight what may be a NoMachine problem and what may not, that’s why I’m posting such questions here.

    #711
    titan
    Participant

    I understand perfectly. I’m certainly not going to blame you. Finding where the problem can be it’s often difficult also for us ;-).

Viewing 5 posts - 1 through 5 (of 5 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.