Keyboard mappings

Forums / General Discussions / Keyboard mappings

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #7889
    iceback
    Participant

    I have not been able to find a current (4.6) listing of the available keyboard shortcuts.  In particular, what is the PC equivalent of the Mac command-p which for me reduces the size of the various windows being displayed in the client.  (They start off somewhat magnified on both platforms and I cannot get the action of command-p on the PC clients)

     

     

     

    #7898
    Bilbotine
    Keymaster

    Hello iceback,

    Could you please give us some clarification about magnifying ?

    We have tested and do not have any reaction to cmd+p.

    Thank you in advance.

    #7914
    iceback
    Participant

    That’s weird.  I guess it just a Mac thing?!

    When I start a new connection or return to an existing connection the client windows are perhaps 50% larger.  Command-p then re-adjusts the windows.

    I use ‘Fit to Window’ and ‘Full Screen’. The Quality setting is at maximum, the Resolution is 1:1. Display: 1920×1080, code VP8

    Nasty secret.  We use NX to get to desktops (4.6) which are all behind a single kvm.  The rest of the group, running on PC clients see only the enlarged view.  I’ve been looking for the PC-equivalent of Command-p for them.

    Happy to round of log files if anyone is interested.

    #7921
    Bilbotine
    Keymaster

    Hello iceback,

    It looks like you use ‘command-p’ to show up the menu where you can adjust the video settings (fit to window, full screen and so on). Is that correct?

    If so, ‘command-p’ is not our default setting. By default we have ‘ctrl-alt-0’, which is valid on all platforms.

    Please check the preferences (see the ‘Input’ menu in the screenshot attached), and let us know if it works now!

    Attachments:
    #7924
    iceback
    Participant

    My input settings are identical except on a mac the string is “⌃⌥0”

    (Btw, clicking on your image cleared out my full posting. Very annoying.)

    No, I use peel back or ctrl-alt-0 to access the NX control. The only keyboard trick I do is to swap capsLock and control keys.  (I use emacs a lot, as should we all.)

    The screens are enlarged whenever I rejoin an NX session. The individual windows on the client desktop are larger then when I left them and Command-p re-sizes them to where I left them.

    Again, we connect to the root console of our server machines (each to his/her own) through a KVM switch, hence a single physical monitor.  This works fine with the exception that the PC clients are seeing only the enlarged version and I’m desperate for whatever Command-p is doing for me.

    Happy to use a debug version is that helps. (I’ll be out of the office Monday, Tuesday)

    #7942
    Bilbotine
    Keymaster

    Hello iceback,

    We made some further tests, and we verified that the same key combination works with NoMachine Keyboard Grabbing activated.

    The equivalent key combination to the MacOSX cmd+P on Windows is: Winkey+p.

    You can find more information on how the Keyboard grabbing can be enabled in the ‘Guide to the Functionality in the Menu Panel’, under the section 3 (https://www.nomachine.com/DT10K00060&dn=#3).

    Please let us know if your problem is solved or not.

    #7946
    iceback
    Participant

    I appreciate your efforts very much.

    I currently do not have “Grab the keyboard” check and I get the toggle behaviour with command-p.  If I check it I do not get the behaviour.  I’m working with others here (PC users) to see if this check box or Windows-p helps them at all.  I will report tomorrow.

    Thanks

    #7962
    iceback
    Participant

    I have checked the box for ‘Grab keyboard’ on a PC client and the Windows-p does toggle the resolution!  (The reverse is true on the mac: I do NOT check ‘Grab keyboard’ ant command-p toggles resolution.

    Up to you if this is to be closed 🙂

    Thanks

    #7965
    graywolf
    Moderator

    Happy to hear that worked for you!

    By the way, I saw that “Grab keyboard” is not relevant on Mac: Cmd+P event is passed through in any case. I cannot say why you need to keep that box unchecked.

    On Windows that is needed because Win+P is usally a shortcut for “switch video output”.

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.