KUbuntu host not streaming audio

Forums / NoMachine for Linux / KUbuntu host not streaming audio

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #716
    sbalmos
    Participant

    Good morning,

    I’m not sure if something has regressed in build 4.0.365_1. I am running a KUbuntu 13.10 VM inside VirtualBox on top of my Win7 host. I will very frequently connect to both the Windows host by RDP, and the KUbuntu VM console session via NX, from my work machine. Both the KUbuntu host and Windows client are Free v4.0.365_1. From what I can tell, audio is no longer streaming from KUbuntu via NX, where it seemingly used to in the original build of 4.0.

    In nonscientific testing, I would start audio playing in the KUbuntu NX session. Audio would actually be playing via the Win7 RDP session, even though “mute audio on server” was checked in the NX connection. This is verified by either muting the Windows audio, or disconnecting the RDP session.

    I can see in the KDE audio setup a null output device, which is disabled, and only the analog stereo output which would normally show up. pactl seems to be listing some NX-related devices. But I am unsure how to read if audio is actually routed through those devices while the NX connection is active.

    Audio tests have been performed using both the default setting of UDP for audio streaming, and disabling that setting in order to force TCP streaming, in order to remove potential firewall issues.

    Ideas anyone? Thanks!

    #736
    barpa
    Participant

    Thanks for reporting this. The developer was able to reproduce it. We have opened a Trouble Report for this bug which you can track here: https://www.nomachine.com/TR11K04052.

    By toggling with the ‘Audio streaming’ slider, sound should come back.

    Menu panel (Ctrl-Alt-0) -> Audio -> Change settings -> Move the Audio streaming slider.

    You can put it back to the middle position. Click Done.

    #742
    sbalmos
    Participant

    Thanks for opening the ticket. However, the noted “fix” does not correct the issue, at least in my observation. I am testing using the Test function on the audio playback device in the KDE Audio Control Panel, FYI.

    Clicking Test will not play audio, under any condition, whether I change the audio quality settings in the session control panel back and forth, or not. One further observation is that, if I toggle the Mute Server Audio setting off and on in the session control panel, the in-session volume (e.g. KDE’s volume of the audio output) returns to its original setting of ~15% volume. I always return it to 100%, however that does nothing. Perhaps volume setting updates are not being processed?

    #991
    Britgirl
    Keymaster

    An audio fix should be coming with the next update, so watch out for that.

    But to make extra sure, are you able to show us output of these commands run in the session while audio is playing?

    $ amixer -c 0 get PCM
    $ amixer -c 1 get PCM
    $ amixer -c 2 get PCM

    $ pactl list | grep -A3 “Source #”

    #994
    sbalmos
    Participant

    sbalmos@triton:~$ amixer -c 0 get PCM
    Simple mixer control ‘PCM’,0
    Capabilities: pvolume pswitch pswitch-joined
    Playback channels: Front Left – Front Right
    Limits: Playback 0 – 31
    Mono:
    Front Left: Playback 31 [100%] [12.00dB] [on]
    Front Right: Playback 31 [100%] [12.00dB] [on]

    amixer for cards 1 & 2 give invalid card number

    sbalmos@triton:~$ pactl list | grep -A3 “Source #”
    Source #0
    State: IDLE
    Name: alsa_output.pci-0000_00_05.0.analog-stereo.monitor
    Description: Monitor of Built-in Audio Analog Stereo

    Source #1
    State: SUSPENDED
    Name: alsa_input.pci-0000_00_05.0.analog-stereo
    Description: Built-in Audio Analog Stereo
    sbalmos@triton:~$

    For completeness, the same output is received when connecting to a similarly-configured OpenSUSE 13.1 VM.

    #1006
    barpa
    Participant

    Can you please send us the log files?

    – Enable debug in server.cfg and node.cfg, uncomment the SessionLogLevel key and set it as it follows:

    SessionLogLevel 7

    – Reproduce the problem.
    – Send content of the /usr/NX/var/log directory on the server host to forum[at]nomachine[dot]com.

    #1216
    Britgirl
    Keymaster

    Fixed in 4.0.368 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.