LAN PCs show as available, but cannot be connected

Forums / NoMachine for Windows / LAN PCs show as available, but cannot be connected

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #36195
    Eugene
    Participant

    When NoMachine (latest free version) runs on either of the 2 PCs I have on my local network they each see the other PC as being on the network.

    One PC is Windows 10, the other Windows 11, if that makes any difference.

    But they will never connect – I just get the ‘Ooops! Connection Timeout message…’

    Nothing I have tried ever works.

    (and yes, I have followed all the provided instructions)

    When first started, nxplayer.bin gets added as an Allowed Program in Windows Firewall, but nothing else. Is something missing?

    #36259
    fisherman
    Moderator

    It looks that your firewall is somehow blocking incoming connection to the port 4000. If you are using Windows default firewall please can you check if firewall rules for NoMachine server are enabled, or please add new firewall rule to accept incoming connection to the TCP port 4000. See screenshot.

    Attachments:
    #36261
    Eugene
    Participant

    I appear to have very different NoMachine options…

    Attachments:
    #36278
    Eugene
    Participant

    So, what do I need to change, based on the different NoMachine options I seem to have?

    And why is this info not readily available?
    I can’t be the only user with such issues???

     

    #36279
    fisherman
    Moderator

    I see that almost all services are assigned to the domain profile. Please check your active network profile for example in my case private (see screenshot), and assign firewall rules to correct profile. Additionally you can make new rule with opening TCP port 4000 and assign it to the active network profile

    Attachments:
    #36281
    Eugene
    Participant

    Not fully understanding – but things look correct.

    (There is a delay with my replies due to ‘moderation’…)

     

    Attachments:
    #36291
    fisherman
    Moderator

    As I mentioned, your firewall profiles are set to allow access only on domain network, so you can edit NoMachine firewall rules and assign Private profile as shown on nxplayer (see screenshot).

    Or you can do following:
    – Click on Inbound rules – New rules
    – Select Protocol and Ports – set (TCP and specify port 4000)
    – Allow the connection
    – On the Profile page select the appropriate options for your environment.
    from your screenshot i see it is Private, or you can use all if Profiles can change often
    (see screenshots)

    #36295
    Eugene
    Participant

    Sorry, I should say I am (presently) only interested in connecting between PCs on the LAN – not via the Internet.
    I have not even tried over the Internet…

    #36317
    fisherman
    Moderator

    I am not talking about Internet connection. You allowed NoMachine on Domain connection, but that connection does not exist on your host, and you have only private network enabled.

    Due to that you should assign NoMachine server or port 4000 to allowed and assign profile Private.

    #36360
    Eugene
    Participant

    I’ve set the two ‘nxserver.exe’ entries to Enabled, and to ‘Private Profile’, with ‘Any Ports’ enabled.
    Still no change.

    I really do not understand why there is no documentation on this, or why when installing NoMachine it seems to get the settings so wrong?
    I know I’m not knowledgeable with such network settings, but really, is this as good as it gets?

    #36376
    fisherman
    Moderator

    About documentation, NoMachine is setting firewall configuration during startup, so there is possibility that it is some different problem that I am not having good idea what to guess.

    Can you please check IPs and service status on the machine you try to access as server. (selected_IPs.png)
    Then go on the client machine and select correct IP that you can access from the client. (Player_edit_cconnection.png

    In anycase, please make single port accept rule for TCP/4000, and assign it to the Private network.

    #36379
    Eugene
    Participant

    Still doesn’t work…

    #36385
    Eugene
    Participant

    I gave in, and changed all rules to ‘Private’, and enabled them all.
    I can now connect from the Windows 10 PC to the Windows 11 Laptop, but not the other way round.
    When trying to connect to the Windows 10 PC from the Windows 11 Laptop I just get the ‘Ooops!’ message…

    All settings are identical on both PCs.
    And both the PC and the Laptop show the ‘other’ as being available as a server machine.

    It really should not be this difficult…
    [Removed] works easily…

    Attachments:
    #36387
    fisherman
    Moderator

    This problem is definitely something with firewall blocking connection.

    1. Can you tell me if you have some antivirus installed that has firewall features.
    2. Did you tried to add new rule for port 4000 in the windows firewall?
    3. As NoMachine does setup firewall rules during installation, can you remove and install NoMachine software?
    4. Please if this recommendation does not help, please collect NoMachine server and client side logs and send them to forum[at]nomachine[dot]com. Please check article how to collect logs How do I collect the NoMachine log files?

    #36411
    Eugene
    Participant

    No other anti-virus installed at all.

    As for rules, see above – I can now connect in one direction, but not the other…
    (But why did I have to enable all rules just to get a connection in one direction?)

    I have twice already uninstalled and re-installed on both PC – no change.

    So why now a connection in one direction only, when all settings are identical on both PCs?

     

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.