Lightweight mode: setxkbmap -model pc105: Error loading new keyboard description

Forums / NoMachine Cloud Server Products / Lightweight mode: setxkbmap -model pc105: Error loading new keyboard description

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2691
    Avatarsnejok
    Participant

    Hello!

    I switched to lightweight mode and found that:

    setxkbmap -model pc105

    doesn’t work with error

    Error loading new keyboard description

    Everything works fine in “normal mode” (virtual session too)

    Server OS: ubuntu-12.04-server-i386.iso

    Client OS: ubuntu-12.04-server-i386.iso and Win XP SP3

    Server: nomachine-enterprise-server-evaluation_4.1.29_6_amd64.deb

    Client: nomachine-enterprise-client_4.1.29_1.exe

     

    #2694
    Avatarsnejok
    Participant

    In the same environment I noticed that changing node address from localhost:4000 to <ip>:4000 breaks NX:

    The session negotioation failed.

    Error: No running nodes found for this server

    Work:

    # /usr/NX/bin/nxserver –nodelist

    NX> 104 Node list:

    Status  Connection Node           Type LB  Weight Limit Label

    ——- ———- ————– —- — —— —– —–

    running encrypted  localhost:4000 NX   yes

     

    Doesn’t work:

    # /usr/NX/bin/nxserver –nodelist

    NX> 104 Node list:

    Status  Connection Node              Type LB  Weight Limit Label

    ——- ———- —————– —- — —— —– —–

    running encrypted  10.10.19.152:4000 NX   yes

    10.10.19.152 – ip of this server

    changing localhost to 127.0.0.1 breaks NX too

    Attachments:
    #2712
    AvatarBritgirl
    Keymaster

    Will be fixed in the next update 😉

    #2722
    Avatarsnejok
    Participant

    Britgirl, excuse me, you mean both problems? 🙂

     

    #2735
    AvatarBritgirl
    Keymaster

    Yes, both.

    #3140
    Avatarsnejok
    Participant

    Hello!

    I switched to lightweight mode and found that:

    setxkbmap -model pc105

    doesn’t work with error

    Error loading new keyboard description

    Everything works fine in “normal mode” (virtual session too)

    Server OS: ubuntu-12.04-server-i386.iso

    Client OS: ubuntu-12.04-server-i386.iso and Win XP SP3

    Server: nomachine-enterprise-server-evaluation_4.1.29_6_amd64.deb

    Client: nomachine-enterprise-client_4.1.29_1.exe

    Now I notice the reverse situation:

    Everything works fine in lightweight mode, but in “normal mode” even “setxkbmap” command gives:

    Error loading new keyboard description
    Operating Systems same

    Server: nomachine-enterprise-server-evaluation_4.2.19_3_i386.deb

    Client: nomachine-enterprise-client_4.2.19_2_i386.deb and nomachine-enterprise-client_4.2.19_1.exe

     

    P.S.: in lightweight mode I noticed “up-arrow-problem” https://www.nomachine.com/forums/topic/nomachine-key-mappings-issue

    #3632
    AvatarBritgirl
    Keymaster

    I am closing this thread. The keyboard problems described should be fixed in 4.2.21. Refer to https://www.nomachine.com/forums/topic/nomachine-key-mappings-issue

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.