Linux audio delay

Forums / NoMachine for Linux / Linux audio delay

  • This topic has 4 replies, 4 voices, and was last updated 1 year ago by Avatarriek.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #26240
    Avatarmindmark
    Participant

    Hi,

    I’m connecting to a NoMachine running on Cento 7 and am noticing audio delay of ~540 millisecs. Does anybody know if  there any pulseaudio tricks that can be done to improve this?

    #26286
    Avatarmkub
    Participant

    Hi,

    At first, you can try to decrease the audio quality in audio settings and verify if delay get improved. Sometimes, reducing system loads works too. Next step would be to verify settings of server’s audio framework. May anything cause conflicts?  Do you use Phonon framework? Do you use any additional software to maintain sound? Is decreasing video quality make any difference in terms of the sound?

    Maybe there are some problems with pulseaudio. Try to kill it and respawn, then restart NoMachine server.

    pulseaudio -k; pulseaudio -D; sudo /usr/NX/bin/nxserver --restart

    #26559
    Avatarvadim_udo
    Participant

    Hello everyone.

    My problem is much more serious. Ubuntu 16.04 is server system, Ubuntu 18.04 is client.  Audio delay (I mean voice/microphone forwarding from client to server) more than 2 seconds on the server. On client voice is realtime.

    Build 6.9.2_1_amd64 free version on both sides.

    Gnome fallback mode on both sides.

    No Phonon. Pulseaudio was fully reinstalled on the server. Various settings on Server was implemented (video/audio quality, videocodecs, etc. was changed). Delay does not changed.

    Please help me.

    #26584
    Avatarvadim_udo
    Participant

    Small update.

    When I open ‘pavucontrol’ utility on server, navigate to Input Devices tab and set ‘Monitor of NoMachine Output’ as fallback source instead ‘NoMachine Microphone’, delay value decrease to ~0.5 second. It fixed my issue, buy I must do that manually after each connect to server.

    Any idea?

    Thanks.

    #26626
    Avatarriek
    Participant

    We had a very similar problem.

    We are using NoMachine Terminal Server to virtualize our callcenter and enable home office for our interviewers.

    We tried different sip clients and OS for the server. With ubuntu 18.04 we also had a 2 to 3 sec delay on both legs. It was independant of the sip client (jitsi, linphone, zoiper), location (on remote site or lan) or the pbx (direct connection to the pbx was without delay). On debian 9 we had a 2 to 3 sec delay, but only in one direction. On debian 10 we now persistently have approx. 1 sec delay on both legs. We settled with this delay for now and have been running hundreds of interviews per day the last week. Of course we would prefer to have no delay at all because it can produce awkward situations sometimes during an interview.

    The server is running as kvm on a high performing proxmox cluster. I don’t know if that might also play a role but I doubt it. We run other servers and the pbx on proxmox, never had any performance problems.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.