Linux machine does not display current state

Forums / NoMachine for Linux / Linux machine does not display current state

Tagged: , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #17109
    AvatarDavid4321
    Participant

    I’m completely new to NoMachine. Actually, I did try it briefly once in the past, but had struggles with setup, and abandoned for TeamViewer. I’m now determined to find an alternative I like.

    My first test implementation is networking Ubuntu 17.10 (Gnome) and Windows 7. Current versions of NoMachine from fresh downloads just installed. (I cannot find version info in application). The Windows machine comes up fine on Linux, all actions and open programs appear on target system and in screen share. When I pull up the Linux machine from Windows, I am seeing a blank desktop with no programs open as they are in current system state, and cursor movements do not appear on live Linux system. It’s as though I’ve logged into a different profile, with nothing open. However, there is only one user profile on this Linux machine, and I logged in using the primary admin user name and password. When I tried opening a program from screen share, Linux tells me it is already open and understands request as for a second instance. What do you suggest?

    #17113
    AvatarBritgirl
    Keymaster

    Welcome aboard 🙂

    I assume you have the latest version 6 from our website.

    Whilst we queue up for investigation, please take a look at this section from the Quick Guide to the NoMachine GUI: https://www.nomachine.com/DT10O00154#3.6. This is how you can identify the version you are using.

    #17114
    AvatarBritgirl
    Keymaster

    I just realised you have Ubuntu 17.10. This uses the Wayland protocol which NoMachine doesn’t support yet. There’s a Feature Request in the Knowledge Base which also includes a workaround until its implementation.  https://www.nomachine.com/FR10N03221

    #17131
    AvatarDavid4321
    Participant

    Thanks. For any who may find this helpful, I found instructions to boot 17.10 into Xorg instead of Wayland. Also gives solution to remove Wayland from session options in a way that is easily reverted.

    https://askubuntu.com/questions/961304/how-do-you-switch-from-wayland-back-to-xorg-in-ubuntu-17-10

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.