Linux Mint 20 headless – wrong keyboard mapping

Forums / NoMachine for Linux / Linux Mint 20 headless – wrong keyboard mapping

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #30178
    AvatarGerdSidan
    Participant

    Hi,
    I’m using NoMachine server on a PC with Linux Mint 20 Cinnamon and NoMachine client on a Windows PC.
    NoMachine version is 6.12.3 on both PCs.
    If a monitor is connected to the Linux PC during boot, everything works well, including the correct keyboard mapping as it is configured on the Linux PC (German QWERTZ).

    However, the intention is to run the Linux PC headless, i.e., no monitor is connected at boot time.
    As advised here
    https://www.nomachine.com/AR03P00973
    I stopped the X server and restarted the NoMachine service on Linux. I let NoMachine create its own display service (embedded X server).
    The display output works well with the desired screen resolution, but the US mapping is used for the keyboard.
    On the Windows PC the correct mapping is also set (German QWERTZ).

    Any suggestions how to set the correct keyboard mapping?

    Thanks.

    #30208
    Avatargraywolf
    Moderator

    Go into Cinammon system settings pane and check for keyboard layout: add German layout if needed.

    #30213
    AvatarGerdSidan
    Participant

    Thank you very much. This has solved the problem.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.