Linux Mint NoMachine remote access from Internet not working

Forums / NoMachine for Linux / Linux Mint NoMachine remote access from Internet not working

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #31301
    AvatarGJQ
    Participant

    Dear NoMachine Forum

    I have install Linux Mint 20 on my PC with NoMachine version 7.0.211 install. I have a problem where I cannot remote access my pc from my mobile using my mobile data. I have set up Port Forwarding on my router but remote access to my pc is not working when using mobile data. I attach my Port Forwarding Set up.

    Appreciate everyone that assist

    Thanks

     

    #31325
    AvatarBritgirl
    Keymaster

    What message are you seeing when connecting via NoMachine? Did you follow the instructions here?

    How to connect over the internet to NoMachine behind a NAT router
    https://www.nomachine.com/AR10R01099

    What you attached appears to be ok, except you should also select a rule for UDP (as outlined in the article) just to make sure.

    Maybe you should look at this trouble-shooting page https://openmyip.com/Dlink-DIR-850L-router-setup. It also gives possible reasons for port-forwarding not working.

     

    #31329
    AvatarGJQ
    Participant

    What message are you seeing when connecting via NoMachine?

    Answer: I got “Could not connect to the server” and “Error is 110: Connection timed out” when connecting using mobile data. For Lan to Lan connection no issues.

    Did you follow the instructions here?

    How to connect over the internet to NoMachine behind a NAT router
    https://www.nomachine.com/AR10R01099

    Answer: Yes. That is I set up Port Forwarding on my router. But I cannot find any information for UDP Port so I leave it blank and TCP Port i put 4000 which is the default port for NX

    What you attached appears to be ok, except you should also select a rule for UDP (as outlined in the article) just to make sure.

    Answer: I don’t understand. Do you mean I have to set up another Port Forwarding for UDP?

    Maybe you should look at this trouble-shooting page https://openmyip.com/Dlink-DIR-850L-router-setup. It also gives possible reasons for port-forwarding not working.

    Answer: I will see and check my config

     

    Thanks for the reply

    #31331
    AvatarBritgirl
    Keymaster

    Answer: I don’t understand. Do you mean I have to set up another Port Forwarding for UDP?

    Yes, like also suggested here: https://forums.nomachine.com/topic/access-multiple-desktops-via-internet#post-23829

    If it still doesn’t work, what you need is the upcoming NoMachine Network feature which will make intervention on the router unnecessary. Sign up to receive a notification of its implementation by following this link: https://www.nomachine.com/FR07J02731.

    #31333
    AvatarGJQ
    Participant

    Dear Britgirl,

    Please see attachment. Updated Port Forwarding configurations. Is this correct?

    Thanks

    #31338
    AvatarGJQ
    Participant

    Dear Britgirl,

    Please see attach for NoMachine status.

    Thanks

     

    #31435
    AvatarBritgirl
    Keymaster

    Everything seems correct in the router set-up. Are you using the computer’s external IP address to create the connection?

    If it still doesn’t work, I don’t know what else to suggest other than to wait for NoMachine Network when all this advanced configuration won’t be necessary.

     

    #31516
    AvatarGJQ
    Participant

    Hi Britgirl

    On my side, I can only do a LAN to LAN connection. There is no GW shown on NoMachine server status on my PC even though I have set up the port forwarding everything in my router. I have uninstall everything in my Linux Mint PC and will try again. Currently a sad ending on my side

    But on another PC install with Linux Mint 20 for my friend, I set up the forwarding in the router and install NoMachine on it. It has got GW port shown on the server and I can connect to it from outside using my mobile data. A happy ending

    I do not understand why the GW port is not shown on my side even though i have set up Port Forwarding while it shown up on my friend pc. I will have to mirror his router settings into my own router and try again.

    Overall good and sad

    Big thanks for your help

     

    #31549
    AvatarBritgirl
    Keymaster

    Sorry to hear that. It could be the router. I suggest you sign up to receive a notification of its implementation by following this link: https://www.nomachine.com/FR07J02731.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.