Local works, but no Public/External IP

Forums / NoMachine for Windows / Local works, but no Public/External IP

Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8273
    edgedbynone
    Participant

    I’ve been using VNC (TightVNC) to connect remotely so far and it has worked OK. I’ve decided to try NoMachine after I saw it recommended as much faster on the internet, and that has been my experience so far on my local network. However, I am unable to have NM work remotely.

    The NoMachine app shows only my local IP address, which starts with 10.0… nothing else is displayed.

    In the NoMachine service, the gateway port was disabled by default. Trying to turn it on yields the error: “Failed to map the port on the gateway”

    I’ve tried opening 20048 (the default gateway port in NM) on the router and *then* enabling, same error.

    I’ve tried opening port 4000, the default port, but the router gave me an error (maybe it’s an excluded range?)

    I’ve then changed the default port (no the gateway, which I can’t even enable) to 4000and restarted the service, and still the NoMachine app showed only the internal IP address (with :40000 at the end)

    I’ve tried advanced settings in Windows Firewall and added rules for 20048 (both inbound and outboound), still no luck!

    I know my way around port-forwarding but I’m not sure that’s the issue at hand.

    What am I doing wrong?

    System Information:

    Host OS: Windows 7

    Host Software running (which might be relevant): TightVNC, Windows Firewall

    Host NoMachine: latest

    Host Router: 1, UPNP enabled

    No other firewalls/antivirus running on host

    Client OS: Mac OS X Yosemite

     

    Any help or guidance appreciated!

    #8302
    irek
    Participant

    It’s difficult to see where the problem might be, so to help us would you be interested in installing a debug package so that we can get detailed logs?Please send an email to forum[at]nomachine[dot]com and let us know. We will then send you instructions.

    Can you also send us the logs from host/server machine ? https://www.nomachine.com/AR10K00697
    and information about model/type of router to which host machine is connected.

    #8318
    edgedbynone
    Participant

    Thanks irek. Thanks for offering to help but I’ve figured what my problem was, I simply needed to keep nx://mydomain.tld and not try to change it to https:// as I thought I should.

    While I’m here, can I ask whether NoMachine should add an “Other…” option to Yosemite’s login page?

    #8553
    Britgirl
    Keymaster

    can I ask whether NoMachine should add an “Other…” option to Yosemite’s login page?

    We’re checking this on the latest version of NoMachine 5.

    #8722
    jvanc
    Participant

    I have just tried using NoMachine on the recommendation that it would be a better remote solution than tightvnc and that it could connect over the internet as well.

    My installation is working but in the guide there is mention of NoMachine detecting the internal and external IP. The only IP address that appears is the local IP but not the external which I understand is what allows the connection over the internet.  There is no mention of having to do any configuration with routers just to establish such a connection.

    This seems to be the same issue experienced by edgedbynone but restarting NoMachine.

    I feel I may be missing something because the guide seems so simple that things should work right of the bat.

    I’ve tried latest free NM installs on three computers win7 home, win7 pro and win 8.1 pro each has and antivirus and the win7 pro is behind a router firewall and located remotely. The only machines that connected were the other two that were getting connection from the same router.

    By its description, I take it that NM can connect over the internet and be an alternative to Teamviewer. Which would mean, to me, that NM would not need for firewalls or routers to be configured just so that a connection can be made.  Am I wrong in this assumption?

    Any guidance would be greatly appreciated.

     

    #8746
    irek
    Participant

    Hello jvanc.

    Currently NoMachine tries to configure automatically a router to allow incoming connections. If it is successful, details of an IP and a port to use to connect are available in the Player GUI.

    Routers supporting UPnP or NAT-PMP are configured automatically to pass connections to NoMachine and all required informations are displayed at initial screen (Welcome to NoMachine).
    Routers not supporting UPnP or NAT-PMP and Firewalls have to be configured manually to pass traffic to port 4000 (NX protocol), 22 (SSH protocol on Linux/MacOSX) or (4022) (SSH protocol on Windows).

    Please check if both routers have enabled UPnP or NAT-PMP in case routers supports this, and enable it.
    In case it still doesn’t help, please provide information about model/type of each router to which host machine is connected.
    Can you also send us the logs from host/server machine: https://www.nomachine.com/AR10K00697 ?

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as closed, you can't post.