Lock local mouse to remote desktop

Forums / NoMachine for Linux / Lock local mouse to remote desktop

Tagged: , ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4263
    twilight-wolf-pa
    Participant

    Ok, here is the problem I am having. I run the free version to connect my desktop to my server. Both systems are running Ubuntu 12.04. When I go to play any game over the connection, minecraft mainly, I can not use the mouse to look around without it messing up. The problem is the game is supposed to lock the mouse to the window but NoMachine doesn’t lock the client mouse. Anyone who has tried to play any game that requires the mouse to look around will know what im talking about. Is there any way to fix this problem? Maby a way to disable the local mouse and use only the remote one. Any help is appreciated. Thanks

    #4281
    graywolf
    Moderator

    Hello.

    I think that it could work if you if attach a second USB mouse to the client host and forward it to the server.

    When you are connected press Ctrl-Alt-0, select “Devices” and “Connect a USB device”. Select the mouse you want to forward and press “Connect”.

    Be aware that forwarded device disappear from client host, so it is better to use a second mouse if you need one on the client while playing the game.

     

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.