Log out button not working 4.2.17

Forums / NoMachine for Linux / Log out button not working 4.2.17

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #2925
    PaulLochhead
    Participant

    Attached an image.  Using GNOME (2.16.0) Desktop, there is an option to Log Out, was working fine in 4.1.29.  Just upgrade to 4.2.17 and the Log Out button no longer works, Cancel works if you get to it right away however Log Out does not.  There is a count down timer associated with the dialog, appears that as soon as the timer starts counting down the dialog is none responsive in NoMachine.  Works fine from the console.  Have tried both SSH and NX.

    NoMachine 4.2.17 on both local and remote.

    Local Windows 7, remote RHEL.

    #2932
    Britgirl
    Keymaster

    Can you try attaching the image again? You can also send it to issues[at]nomachine[dot]com.

    #2947
    PaulLochhead
    Participant

    Sent to to issues[at]nomachine[dot]com

    #2981
    Britgirl
    Keymaster

    We got your screenshot and are investigating. Can you send us logs (of the problematic session) and also tell us if you have lightweight mode enabled on the server. You can check this by:

    – open the NoMachine GUI from the Programs/Applications menu
    – click on the last icon ‘Preferences’
    – select ‘Server status’
    – select ‘Server preferences’
    – select ‘Performances’
    – check the box  ‘Use lightweight mode in virtual sessions’

    #3039
    PaulLochhead
    Participant

    Discovered this also affects our console, which we access outside of no machine.  Have uninstalled 4.2.17_13 and gone back to 4.1.29_7.

    #3005
    PaulLochhead
    Participant

    I checked the lightweight mode on the server by looking at the node.cfg file, it was off and I tried turning it on.  shutdown/startup after change no effect.

    There is nothing in the logs, through GNOME I simply choose System-Log out .. get the screen I sent you and their is no response. There are 4 of us using the FREE windows client to access our Linux servers; the 4.1.29_1 client and the 4.2.17_13 client have the same behavior around this issue. When we were using 4.1.29_7 on the server and there was no issue for any of us using the 4.1.29_1 client.  As soon as we went to 4.2.17_13 on the server this behavior started.

    At this point we are monitoring our session will nxserver –list and terminating from the server.

    #3050
    graywolf
    Moderator

    Can you please explain this better? What do you mean with “which we access outside of NoMachine”? How going from one NoMachine version to the other may affect the program if you are not accessing it through NoMachine?

    Could you send the output of ps -ef –forest at the time the problem occurs?

    Have you also checked Gnome logs in $HOME/.xsession-errors?

     

    • This reply was modified 7 years, 5 months ago by graywolf.
    #3053
    PaulLochhead
    Participant

    When we access the console we go through vSphere Web Client versus the NoMachine windows client.

    Installing 4.2.x on the server effectively makes it so you cannot Log Out of your GNOME session, this is true if we use vSphere Web Client or NoMachine Windows client ( 4.1 or 4.2 ).

    Going back to 4.1.x on the server eliminates this behavior and all works as expected.

    Again there are no errors in any logs, we simply choose to Log Out of the GNOME session and the buttons in the dialog image I sent you [Cancel and Log out ]are not enabled OR do not respond to a mouse click.  All we can do is hit the X in the top right to forces a termination of the dialog.

    As there is no way to Log out of the session we must use nxserver –terminate to kill the session(s).

    #3069
    graywolf
    Moderator

    Could you please specify the exact version of RHEL are you using?

    Do you confirm that just installing version 4.2.17 is enough to create the problem? Does the problem show up in the console even if you never used NoMachine for the remote access?

    Does the problem occur after you stopped the server (/usr/NX/bin/nxserver –shutdown)?

    Is it possible for you reproducing the problem and sending the server logs and the output of ps -ef –forest?

    You can find instructions to gather server side logs here: https://www.nomachine.com/AR07K00677

    #3097
    szym
    Participant

    Hi, the problem is with ALSA audio engine, to workaround this, please change value of AudioInterface in file /usr/NX/etc/node.cfg from alsa to disabled. After that, you need to restart server using command /usr/NX/bin/nxserver –restart (It will close all your active virtual sessions). The patch to solve this issues is under development

    #3193
    Britgirl
    Keymaster

    Will be fixed in the next release: https://www.nomachine.com/TR04L04356

Viewing 11 posts - 1 through 11 (of 11 total)

This topic was marked as solved, you can't post.