Login as a guest user

Forums / NoMachine Cloud Server Products / Login as a guest user

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5566
    AvatarPPG2014
    Participant

    Good evening,

    I am using NoMachine Enterprise Desktop Evaluation version 4.03.30 (on linux server), and NoMachine Enterprise Client for Windows – version 4.3.24 (Windows client). When you connect the session option does not appear to go as user guest,  as in the example image attached.

    thank you.

    #5581
    AvatarPPG2014
    Participant

    Can someone help me? Why is this: when a client connects to the server, does not appear the option to connect as a guest account. you can only connect with the local account of ubuntu server. what needs to be done?

    #5588
    AvatarHaven
    Contributor

    Hello PPG2014,
    to enable guest login you need: NoMachine Enterprise Server, NoMachine Cloud Server or NoMachine Terminal Server.

    Product: NoMachine Enterprise Desktop does not have this feature enabled.

    After installing appropriate product you must enable guests by executing command:
    /etc/NX/nxserver –ruleadd –class feature –type enable-guest –value yes

    #5612
    AvatarPPG2014
    Participant

    Hello,

    ok, now I understand how to do. but when you run that command, ubuntu did not find the directory. where is this parameter?

    thank you

    #5617
    AvatarHaven
    Contributor

    Hello PPG2014,
    you can add this rule by executing one of those commands:
    /etc/NX/nxserver --ruleadd --class feature --type enable-guest --value yes
    or
    /usr/NX/bin/nxserver --ruleadd --class feature --type enable-guest --value yes

    Command must be executed as administrator. So execute this from root account or add sudo on the beginning.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.