Login failure from Win to EC2/Ubuntu

Forums / NoMachine for Linux / Login failure from Win to EC2/Ubuntu

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #9502
    curtin
    Participant

    Hi,

    I have a Windows Laptop connecting to EC2/Ubuntu image that I can’t get working, I get login failure from NX/Laptop, it works fine with Putty … it may be the way the account nx is configured on my EC2/Ubuntu instance.

    I have installed NX 5.X on my Windows box, I use “ec2_IP\ubuntu” with password to get
    on EC2/Ubuntu side, I tail -f /var/log/auth.log

    Dec 30 18:29:22 ip-XXXXX nxexec: pam_unix(nx:auth): check pass; user unknown
    Dec 30 18:29:22 ip-XXXXX nxexec: pam_unix(nx:auth): authentication failure; logname= uid=119 euid=0 tty= ruser= rhost=

    now, I have SSH:

    # Change to no to disable tunnelled clear text passwords
    PasswordAuthentication yes

    I can login with putty, with putty.exe -ssh ubuntu@XXXXX

    $ /usr/NX/bin/nxserver –usercheck ubuntu
    NX> 500 NoMachine passwords db is disabled.
    NX> 500 NoMachine users db is disabled.
    NX> 500 Access to NoMachine for user: ubuntu is enabled.

     

    PS C:\Users\curtin1060> [System.Environment]::OSVersion.Version
    Major  Minor  Build  Revision
    —–  —–  —–  ——–
    6      3      9600   0

    #9519
    Mth
    Contributor

    Hello,

    There should not be any problem with connecting to the EC2 server through NoMachine using username and password combination (using standard configuration).

    In your case the issue might be with the username you enter in the Player application – “ec2_IP\ubuntu”. The server’s IP is entered when creating connection, as username it specifies that it is a domain name. When no domain is configured on the server “ubuntu” should be enough.
    So please try it like that from NX.

    If you keep getting “authentication error” using “ubuntu” username though, there could be a problem in your configuration as by default EC2 standard authentication method is by key pair – so in this case please double-check if you do not need to use private key authentication through NX.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.