Login Problem – Mac Mojave

Forums / NoMachine for Mac / Login Problem – Mac Mojave

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #19722
    ggarcia
    Participant

    Hello,

    I upgraded to MacOS Mojave yesterday evening and I cannot connect to my NoMachine Mac server anymore.

    The first problem I found was that I could not type the password any more on the Mac login.  The keystrokes were not sent to the server.

    After closing the NX window and restarting the connection again, I got the NoMachine login prompt okay, but I did not get the Mac login prompt any more and I got “Attempted to reconnect” message.

    The NoMachine client version is Windows 6.2.4  I need to check the NX server version but I think it should be close to up to date.

    Thanks,

    Gerardo

     

    #19750
    Sou
    Participant

    Hello,

    I have the same problem too after updating to MacOS Mojave, the Mac does not accept any input from keyboard as well as mouse.

    The version of NoMachine being 6.2.4.

    Any help would  be appreciated!

    Regards,

    Sou

     

    #19757
    Britgirl
    Keymaster

    Hi, we are aware of issues when connecting to Mojave and are investigating. We have opened a Trouble Report which you can view here: https://www.nomachine.com/TR09P08873.

    We’re also in the process of inserting an article with instructions on how to workaround the problem. When it’s available it will show up in the list here: https://www.nomachine.com/knowledge-base.

    #19759
    ggarcia
    Participant

    Hello,

    I reinstalled again NoMachine 6.2.4 on my iMac running MacOS Mojave, and I can login now without problem.

     

    Gerardo

    #20310
    vertico
    Participant

    In macOS Mojave you need to go to System Preferences->Security&Privacy->Accessibility and enable either “NoMachine” or “NX node”

    Your KB and mouse will then work with NoMachine in Mojave. I’ve tested this several times, works every time.

    New NoMachine users should note that if you are performing a new NoMachine setup in Mojave that you must first attempt to connect to the remote machine via NoMachine in order for the entry to show up in Accessibility to be enabled.

    • This reply was modified 3 years, 2 months ago by vertico.
    • This reply was modified 3 years, 2 months ago by vertico.
Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.