Login successfully on 5G but not Wifi

Forums / General Discussions / Login successfully on 5G but not Wifi

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #41122
    davidyanglee
    Participant

    Hi,

    When I use my phone’s 5G to log into another NoMachine it works fine (via NX protocol, and port# displayed in the NoMachine service); however, when I do the exact same, except my phone is on any WiFi (home or work), I get the “Could no connect to the server. Error is 111: Connection refused” message. So my guess is that the issue is not at the server site but on the out-going side? Any idea how to resolve this?

    Best,

    David

    #41234
    Britgirl
    Keymaster

    Hi, this usually means that the client side cannot reach the NoMachine service on the remote host.  Are you able to connect with WiFi when you are on the same LAN as the NoMachine server? What version and products of NoMachine are you using on the client and server sides? What OS is on the phone, what is on the server side?

    #41252
    davidyanglee
    Participant

    Interestingly on the same LAN I can’t connect (using the phone on WiFi), I have to put it on 5G mobile for the phone’s NoMachine to log in. Devices are running latest NoMachine available this time (free version). I have also tried login from another remote LAN that didn’t work either. So something on the client LAN side is causing this, and that’s not being blocked when I use 5G mobile data. Antiviral is possible but I am using the same phone, different results. Thanks for any suggestion!

    #41253
    davidyanglee
    Participant

    Just checked more carefully, server version is 8.1.2; client desktop 8.1.2 (when I attempted from desktop client, apparently same issue); android v6.1.9. Also, both desktop and android maybe about 6 months ago were working correctly but I think that was back in v7.x.x

    #41254
    davidyanglee
    Participant

    And sorry I didn’t mean to say remote LAN, I meant login in from a remote network that’s different from the server.

    #41268
    Britgirl
    Keymaster

    Could something have changed in your LAN’s configuration?
    Is the phone’s IP address in the same subnet as the server?
    Can you ping the phone from PC on which NoMachine server is installed?
    Can you ping desktop client from PC on which NoMachine server is installed?
    Can you ping the PC (where you have installed NoMachine server) from the desktop client?

    Are you sure you’ve (or someone else) has not changed the port on the server to a different port than 4000?
    To what port on the router did you redirect the connection from the Internet to the NoMachine server?

    What is the OS on the NoMachine server? Does the server have a firewall?
    Can you temporarily turn off firewall during LAN connection tests?

    #41339
    davidyanglee
    Participant

    Turns out it is the Ubuntu servers’ UFW firewall. Probably an update at some point (happened to all my Ubuntu server machines). It allowed IPv6 login (e.g. IP address from 5G network) but blocks all unknown IPv4 addresses. So I just added my work’s IP IPv4 address and port and they worked. Thank you for your help in troubleshooting.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.