Lost window controls after 6.8.1

Forums / NoMachine for Linux / Lost window controls after 6.8.1

This topic contains 5 replies, has 4 voices, and was last updated by Avatar Britgirl 1 week, 1 day ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #23746
    Avatar
    EddieA
    Participant

    Just updated my Slackware 14.2, KDE/Plasma  5.17.11 (with NoMachine supplied startSession.sh) to the latest 6.8.1.

    Following this, when opening Firefox, Thunderbird, I no longer have a title bar, with the window controls.  Also cannot select an edge of the window to drag and resize.  Pull down menus display, but moving the cursor to select an option closes the menu.

    Fired up the ESXi console, started a native KDE session, and everything works correctly there.

    Cheers.

    #23788
    Avatar
    kroy
    Contributor

    This is not a NoMachine bug, but rather an issue in Slackware and how it handles KDE 5 which is not its default desktop environment. We had a look and found that this works:

    Try to modify startSession.sh script and add window manager startup command.

    Edit as root the last line script to looks like this:

    /usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/startkde --failsafe & /usr/bin/kwin_x11 --replace

    #23791
    Avatar
    EddieA
    Participant

    Maybe not a NoMachine bug per se, but something changed between releases.

    That looks like it fixed it.  Thanks.

    Cheers.

    #23871
    Avatar
    willaaam
    Participant

    Hi Everyone,

    I have the exact same issue on Kubuntu and KDE Neon. Also here – it worked fine with 6.8.1. Just wanted to let you know that something did indeed change and to me it does act up like a bug (unexpected behavior).

    #23874
    Avatar
    willaaam
    Participant

    Also – tried using the suggestion above but replacing kwin_x11 from root leads to incorrect settings loading, defaulting to higher dpi so I suppose that’s not really right solution here. Downgraded to 6.7.6_14 amd64 for the time being.

    In addition to what I wrote above, it obviously does not work fine with 6.8.1 — it did work fine with the earlier 6 series releases.

    #23902
    Avatar
    Britgirl
    Keymaster

    Hello, a Trouble Report has been opened: https://www.nomachine.com/TR10Q09425

    You can sign up to receive notification of when a fix has been officially released using the ‘notify me’ service.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.