Low framerate on high quality

Forums / NoMachine for Windows / Low framerate on high quality

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #26195
    AvatarJulienCC
    Participant

    Hello,

    I’m trying to use NoMachine to play on a remote server from my laptop. Both run on W10.

    The laptop and the server are on the same LAN, connected through gigabit ethernet to the same switch.

    When I set the stream quality to the lowest, the stream is quite smooth (even if it seems to be limited to 25/30 FPS or so).

    The more I increase the quality, the lower the FPS, with FPS drops when the rendered sceen changes a lot.

    The CPU,GPU and network usage dont seem to scale as I would expect, neither on the laptop nor on the server.

    This software looks promising as it already works better than everything I have tried so far. But since neither the CPU nor the network are at full charge I feel like it could be way better.

    I attached the log of a short problematic session.

    #26221
    Avatarfra81
    Moderator

    Hi,

    as far as I understand there should be no problem with available network bandiwidth, but in the statistics I see that network latency is quite high. This could be another cause for reducing the throughput. Please try to edit the ‘C:\Program Files (x86)\NoMachine\etc\node.cfg file on the server machine as explained in this FR:

    https://www.nomachine.com/FR03O03364

    Then start a new connection and see if it helps.

    #26224
    AvatarJulienCC
    Participant

    Thank you for pointing out the fact that the latency was too high.

    Since I messed with my laptop’s NIC parameters recently I decided to revert the changes to default and everything is perfectly smooth now.

    I don’t know which parameter did the trick (I had disabled most of Offloading and Packet priority) but it works great now.

    Thanks a lot !

     

    #26236
    Avatarfra81
    Moderator

    I’m glad your issue is fixed 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.