Lower-res remote down-scaling for Retina

Forums / NoMachine for Mac / Lower-res remote down-scaling for Retina

  • This topic has 6 replies, 2 voices, and was last updated 2 months ago by AvatarTor.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #29496
    Avatarkleinfelter
    Participant

    I’m getting down-scaling when connecting my Retina Macbook at 2880 x 1800 to a PC with a 1920×1080 display.  It makes it hard to read text.

    I’m guessing that maybe pixel-doubling happens and then it down-scales.  I understand the value of pixel-doubling. Otherwise, the remote display would be tiny on the Retina screen.

    I’d like to enable the scrolling viewport mode.  When I connect to a Linux remote running 1920×1080, I get a nice, pixel-perfect viewport display. It behaves as if the remote were a larger display than the Mac, with viewport scrolling.

    But when I connect to the PC, it behaves is if the remote were a larger display with scaling.  How do I make connections to the PC remote behave like connections to the Linux remote?

    Mac is using NoMachine 6.11.2. PC is using 6.11.2.

    #29543
    AvatarTor
    Contributor

    Hi. Can you compare display settings between those two connections and verify that they’re the same? More precisely verify that “Fit to window” is not checked when connecting to Windows.
    Do you’ve a scaling different than 100% in Windows display settings?

    #29626
    Avatarkleinfelter
    Participant

    Thank you for your reply.  “Fit to window” is NOT checked on either remote.

    When I view the display settings in NoMachine for the Windows connection, I don’t see a ‘scaling’ setting.  I have display quality set to medium, and resolution is set to 1920×1080 (which is the resolution used by the Windows machine).

    Hmmm… So I went into “Get Info” on the Mac, and told it to make NoMachine “Open in Low Resolution”, which uses pixel doubling to hide Retina resolution from the app.  That told NoMachine that my Mac had a lower resolution than the Windows machine, and it gave me a scrolling viewport onto the ‘higher resolution’ Windows machine.  That’s what I’d expect.  But then I cleared “Open in Low Resolution” and restarted NoMachine on the Mac, and it *still* behaves as if the Mac had lower resolution than the Windows machine.

    #29637
    AvatarTor
    Contributor

    When I view the display settings in NoMachine for the Windows connection, I don’t see a ‘scaling’ setting.

    I was talking about the Windows display settings, you can see the dialog attached to this post.

    But then I cleared “Open in Low Resolution” and restarted NoMachine on the Mac, and it *still* behaves as if the Mac had lower resolution than the Windows machine.

    Did you try to restart your macbook? Do you use default retina configuration, or is it scaled to More Space?
    Do you mind compressing and sending the directory ‘.nx’ in your home to forum[at]nomachine[dot]com? Thanks.

    #29641
    Avatarkleinfelter
    Participant

    I tried removing NoMachine (and the .nx directory and the ~/Documents/NoMachine connection files), and re-installing with the latest .dmg from NoMachine.  And rebooting.  Same behavior.  NoMachine behaves as if my Mac 2880 x 1800 has a lower resolution than the remote Windows machine at 1920×1080.  It sure looks like NoMachine is pixel-doubled on the Mac.

    I confirmed that the “Open in Low Resolution” checkbox is clear on the Mac.  My Retina Display options in System Preferences are set to “Default for Display”.

    The Windows machine is typically set to scale to 125%.  I set it to 100% with no change in behavior. That made the text smaller, but the viewport is still the same size.

    I’m running MacOS 10.13.6.  (I have some critical 32-bit apps, so I simply won’t be updating MacOS.)

    nx.zip emailed to the specified address.

    The problem appears to be on the Mac.  When I connect to a Linux host and set “Change the server resolution to match the client when I connect”, the Linux host switches from its normal 1920×1080 to 1440×900.  NoMachine on my Mac thinks I’ve got 1440×900.  And yes, I did confirm that About This Mac says “15.4-inch (2880 x 1800)”.

    Thank you for your help!

    #29642
    Avatarkleinfelter
    Participant

    OK.  I apologize.  The fault is mine.  Apparently, I have been running my Macbook at 1440×900 for the last 5 years without realizing it.  I downloaded Display Menu from the Mac App Store, clicked on 2880×1800, and suddenly everything is tiny and when I connect to distant NoMachine hosts, I get all the resolution I expect.

    Sheesh!  I thought I was scaling everything at Retina but I’ve been pixel doubling all along.  Oops.

    #29661
    AvatarTor
    Contributor

    No problem, retina displays are great but sometimes they bring a bit of confusion. 🙂 Thank you for your report.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.