MacOS remote – special keys never get forwarded even with grab keyboard/mouse

Forums / NoMachine for Mac / MacOS remote – special keys never get forwarded even with grab keyboard/mouse

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #33326
    Avatarnomameswei
    Participant

    Hi there,

    Running 7.4.1 on Fedora 34, connecting to MacOS 10.14.4 running 6.14.1, proper permissions and privacy stuff in place.

    Essentially everything works except keyboard shortcuts – can’t copy-paste, switch programs, essentially nothing other than basic text input works.

    Setting grab keyboard/mouse makes no difference, the shortcuts are always active on local rather than remote.

    What am I missing? Does your software actually have support for shortcuts being forwarded to MacOS clients?

    #33374
    AvatarTor
    Contributor

    Hi. Can you please verify if shortcuts are correctly forwarded when NoMachine client window is fullscreen? Don’t forget to enable keyboard grab option, it is required to catch also shortcuts used by your Linux system.

    #33381
    Avatarnomameswei
    Participant

    Hi, no they don’t work. I tried it in fullscreen, windowed, another monitor, virtual desktop, with grab and without grab. What works 100% of the time is the host shortcuts (gnome 40 responds to both ALT+TAB with SUPER+TAB). If I hold down 1 modifier key alone, it will get passed to remote but following that up with any other key results in failure.

    #33382
    Avatarnomameswei
    Participant

    Wow you guys are super tough on moderation here. Takes 3 days for a moderator to approve a post. I better find a hobby because this is going to take a while 🤣

    #33401
    AvatarBritgirl
    Keymaster

    nomameswei, all content submitted goes into moderation and this appears to have slipped through the net (human error? maybe, but we are all human, including the moderator), but I see that you got an answer from one of our developers the day after your topic was published. So within 24 hours ๐Ÿ˜‰

    Remember that the forums is a place for users of the free version to get free support. Whilst we take all questions seriously, whatever the channel they are coming to us (and we check one by one) we respond to all of them whether it’s a report issues report, a contact request, a forum submission, a direct email, social, and finally support enquiriesย  for customers which have support contracts with us. Because of the quantity of communications to which we have to respond, we ultimately have to prioritize who to respond to first. This doesn’t mean, however, that we haven’t read a user’s topic or comment and queued up the potential bug for further investigation. Thanks for your patience.

    #33454
    AvatarTor
    Contributor

    I tried it in fullscreen, windowed, another monitor, virtual desktop, with grab and without grab.

    You NEED keyboard grabbing if those shortcuts are being used by the local system. ๐Ÿ™‚
    You’re probably using Wayland, this is the reason why it is not working. The problem is documented here:

    https://www.nomachine.com/TR10P08952

    Since you’re using GNOME you can try the following workaround:

    1. Enable input grabbing in Wayland

    gsettings set org.gnome.mutter.wayland xwayland-allow-grabs true

    2. Print the whitelisted applications

    gsettings get org.gnome.mutter.wayland xwayland-grab-access-rules

    3. Append ‘nxplayer.bin’ to the existing application classes. “App A” is an example, your whitelist could be empty so you just need to add the player

    gsettings set org.gnome.mutter.wayland xwayland-grab-access-rules "['App A', 'nxplayer.bin']"

    4. Launch the player by enabling the active window grabbing

    /usr/NX/bin/nxplayer --activegrab

    #33457
    Avatarnomameswei
    Participant

    Oh ok, that’s good if you’re aware. Yes, you are correct, I am using Fedora 34 which comes with Wayland and GNOME 40 by default.

    The workaround doesn’t have any effect – shortcuts are still only active locally in Linux.

    $ gsettings get org.gnome.mutter.wayland xwayland-grab-access-rules
    ['nxplayer.bin']
    
    # started as
    $ /usr/NX/bin/nxplayer --activegrab
    #33491
    AvatarTor
    Contributor

    The client is not swapping keys between Linux and macOS, so if you want to send Command + C you’ll have to press the keyboard button corresponding to “Command” on Mac (for example on a Windows keyboard it would be the Windows button). Can you confirm you’ve used shortcuts in this way?

    #33492
    Avatarnomameswei
    Participant

    […] I tried it in fullscreen, windowed, another monitor, virtual desktop, with grab and without grab. What works 100% of the time is the host shortcuts (Gnome 40 responds to both ALT+TAB with and SUPER+TAB […]

    Nothing changed between my initial report and now. Therefore NoMachine still does not send any more than 1 single modifier keystroke over to the client. It doesn’t matter which one it is. Any modifier + modifier or modifier + [a-z0-9] either end up being interpreted as simply [a-z0-9] without the modifier, or in the case double modifiers it is responded to by the host alone, if a valid shortcut. Otherwise, it gets ignored – aka never makes it to the client regardless if NoMachine has to fight the OS’ active shortcuts or not.

    For example: Super + C does nothing in Gnome 40, there’s no shortcuts assigned. If I type it in NoMachine it gets ignored. Pasting doesn’t contain the text selected on the MacOS client (yes copy paste works otherwise).

    #33730
    AvatarTor
    Contributor

    Nothing changed between my initial report and now.

    So far we could not reproduce the issue you’re describing, with the Gnome configuration I’ve suggested above. Could you contact us at forum[at]nomachine[dot]com, so we could send you a client automatically dealing with the compositor requests in order to exclude some trivial problems?

    #34010
    AvatarCarin
    Participant

    Hi nomameswei,

    We have sent you the package as requested via email. Please check your inbox ๐Ÿ˜‰

    #34017
    Avatarnomameswei
    Participant

    Hello!

    Reporting back:

    • disabled settings you had me override initially
    • replaced the bin files as instructed, moved virgin ones out of bin

     

    If I enable grab keyboard for a macOS connection it now successfully sends over the SUPER key + tab, so I can switch tasks! I can also copy paste via shortcut which is a HUGE time saver. Thank you! ๐Ÿ™‚ I can now properly use my old headless mac.

     

    Just for fun I also tried it connecting to a 10.15.6 macbook pro, worked as it should.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.