Macs do not appear in connection window

Forums / NoMachine for Mac / Macs do not appear in connection window

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #37161
    bbuice
    Participant

    I have multiple Mac’s in my home network and none of them appear in the connection window like my Windows PCs do.  I can use any of the Macs to initiate connections and that works fine.  I suspect that the Mac’s are going to sleep and as a result the NoMachine server on them can’t be seen.  I have searched these forums for an answer but can’t find a solution.  I have checked to make sure all of the various permissions have been properly enabled.  Any assistance would me very much appreciated.

     

    Benny

    #37180
    Britgirl
    Keymaster

    Did you already check that the box “Don’t advertise the computer on the network” is not flagged on the Mac machines?

    The NoMachine MDNS service uses the UDP port 5353. Check whether the firewall on those Mac computers is maybe blocking access to it.

    #37198
    bbuice
    Participant

    Thanks for your response. Yes, the box is properly checked.  I did a little more testing and the Mac’s a visible until they go to sleep.  I can go to one of them and wiggle the mouse causing the login screen to pop up then that Mac will show up in the connection screen of the other machines.  It will stay visible until it goes back to sleep.

     

    I should mention that all of them have been upgraded to the free version 7.7.4.

    They are all Intel based Mac’s of various ages and are running macOS Big Sur, Catalina and Monterey.

    #37199
    bbuice
    Participant

    I was just looking through the list of posts and there are others who have posted about this same issue with no apparent resolution.  I would be glad to assist from my end in resolving this issue.  Just let me know what you need from me.   Thanks again.

    #37214
    Britgirl
    Keymaster

    If the Macs are going to sleep, it’s normal that you can no longer see them in Machines of the Player: the Mac suspends applications and this means that broadcast information of the NoMachine server on the LAN is no longer received on the NoMachine clients.

    There are two things you can try:

    1) Configure the Macs’ Energy Savings appropriately so they don’t go to sleep.

    2) if number 1) is not an option for you, create connection files using the LAN IPs of those Macs and store them on the computers/devices you are connecting from. Use these to start the connections (they are identifiable with the small !M icon in Machines) from the Player.

    If the connection still fails to properly wake up your Macs, edit the configuration of the connection visible in the Machines list, and tick the box “Wake on LAN” (Right click on connection icon -> Edit connection -> Configuration -> tick box).

    Let us know the outcome.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.