Manjaro/gentoo virtual screen – KDE taskbar not showing/starting

Forums / NoMachine for Linux / Manjaro/gentoo virtual screen – KDE taskbar not showing/starting

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #39908
    shelter
    Participant

    If I connect to a virtual screen instead of an existing desktop session, the KDE taskbar is missing.

    Same happens on both Manjaro and Gentoo. I first thought it was a gentoo issue but it wasn’t.

    Default manjaro installation.
    DE: Plasma 5.24.6
    WM: Kwin

     

    #39924
    Britgirl
    Keymaster

    Please follow the configuration tips for Arch-based installations which are from a separate topic:

    Help changing resolution on connection

    I’ve pasted them here for your convenience

    1. Create a backup of nx PAM configuration (sudo cp -a /etc/pam.d/nx /etc/pam.d/nx.original). Then change /etc/pam.d/nx in this way:

    auth       include       system-login
    account    include       system-login
    password   include       system-login
    session    include       system-login

    2. Change DefaultDesktopCommand in /usr/NX/etc/node.cfg in order to have this on KDE:

    DefaultDesktopCommand "/usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/startplasma-x11"

    3. Stop display manager:
    sudo systemctl stop display-manager

    4. Restart NoMachine:
    sudo /etc/NX/nxserver --restart

    Does the taskbar appear?

    #39929
    shelter
    Participant

    No, that just gave me a black desktop. I think the issue I was facing was due to that it tried to connect to a running Xorg server and it couldn’t find the display/screen which’s a somewhat known problem on laptops if the lid is closed.

    However I also would like to have to be able to chose between a virtual desktop or running Xorg server. If I have Xorg running it connects me straight to that “session/server”. I can’t figure out what configuration I need to change for that.

    #39944
    Britgirl
    Keymaster

    If you have the lid closed on the laptop you should stop the graphic interface and use it as a headless machine. The remote session will then work as a virtual session (see this article for futher information: https://kb.nomachine.com/AR03P00973). hen connecting via NoMachine to a headless Linux, it will detect that no display is running and ask you if you want to create one.

    If the lid is open, Xorg will work as it should and physical sessions will work correctly.

    #39947
    shelter
    Participant

    Yea, adding a dummy display made things work, no black screen… I’ll play around some more later, I need to tweak the configs a bit.

    #39950
    shelter
    Participant

    There are some tricks to get it working even if the lid is closed. You can also add a custom resolution if you’re limited by the laptop screen resolution.

    I’m now logged in to the X server session when the lid was closed, running in 1080p (the laptop screen supported only 720p), KDE taskbar works and there’s no slowness/lag.

    To get the display running when the lid is closed you need to do the following:
    1. First find your display id (in this case it’s, eDP-1), just run xrandr in an X terminal window.

    2. Make a script containing the following and put it in KDE Autostart as a login script, make sure the script is executable (chmod a+x <script>):

    #!/bin/sh
    (sleep 5s && xrandr –output eDP-1 –auto) &

    3. Add custom 1080p resolution to the session, run this in an X terminal window:

    xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    xrandr --addmode eDP-1 "1920x1080_60.00"

    4. Change to the 1080p resolution in gnome/kde/xfce or whatever DE you’re running.

    No dummy display dongle neeeded!

    #39970
    shelter
    Participant

    I can’t edit the above post but I finetuned the scripting a bit, and adding plasmashell –replace at the end solves all problems.

    !/bin/sh
    (sleep 5s && xrandr --newmode "1920x1080_60.00" \
    173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync && xrandr
    --addmode eDP-1 "1920x1080_60.00" \
    && xrandr --output eDP-1 --auto && plasmashell --replace) &
    #39975
    Britgirl
    Keymaster

    Maybe the low resolution the headless physical display had was the cause of the KDE problems. Glad to know you’ve solved your issues anyway. Although I’m not quite sure if you’ve resolved the “black screen” or “missing kde taskbar” 🙂

    #39984
    shelter
    Participant

    I did manage to get the virtual desktop working but I felt the performance wasn’t the same as using the Xorg server session, so I went ahead trying to fix that session instead.

    Regarding the missing KDE taskbar in the session, specifically the Xorg session, the command plasmashell --replace fixes it.
    The xrandr --output eDP-1 --auto command in the script fixes the slowness if the lid is closed on the laptop.
    The xrandr modelines adds a custom 1080p resolution, my laptop screen supports 1080p but the mode isn’t detected automatically, so those lines doesn’t apply for everyone.

    #40022
    Britgirl
    Keymaster

    In our case, we also found that

    DefaultDesktopCommand "env DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/$(id -u)/bus /usr/bin/startplasma-x11"

    should be enough to start virtual sessions on Arch/manjaro with KDE Plasma.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.