Max resolution NoMachine

Forums / NoMachine for Linux / Max resolution NoMachine

This topic contains 7 replies, has 2 voices, and was last updated by Avatar Tor 1 month, 3 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #23489
    Avatar
    Finnish
    Participant

    We’re using NoMachine Workstation and we have problem with max resolution host.

    We have remote host with Quadro P4000 without monitors (Centos 7, KDE, NoMachine Workstation).

    We have workplaces with two monitors 2560×1440.

    When i’m connecting to remote host (P4000) and use window (or full screen), that we have only max resolution 4096×1440.

    Is it possible to use a higher screen resolution?

    We want use 5120×1440 (or 1360 if it’s window).

    Attachments:
    #23519
    Avatar
    Tor
    Contributor

    Hi.
    The maximum resolution is limited for a bunch of reasons (e.g. H.264 has a maximum frame size), but we’ve implemented some improvements allowing us to be more complaisant. 🙂 Thanks to this, in our testing version we’ve doubled the maximum resolution.
    The change is documented here so you can subscribe to be informed when it’ll be released:

    https://www.nomachine.com/FR09Q03868

    If you’re connected to a virtual desktop and if your client supports a resolution width bigger than 4096 you can enable the remote resize (from Display toolbar) and increase the window size up to the resolution you need. The client will try to reach that resolution to work around the custom resolution size constraints.

    #23525
    Avatar
    Finnish
    Participant

    Ok. What is it about VP8?

    Earlier we used NX 3.5 and we could set resolution we need.

    #23529
    Avatar
    Tor
    Contributor

    Switching to VP8 would not help because, as I said, the H.264 codec is only one of the reasons why there is a limit. We’ll release shortly (couple of weeks) the version with the improvement I’ve explained.

    #23686
    Avatar
    Finnish
    Participant

    I tried the new version.

    I have 2 monitors 2560×1440. Max resolution 5120×1440.

    But NoMachine can install 5119×1368.

    It isn’t big problem but it’s need to know=)

    #23739
    Avatar
    Tor
    Contributor

    Hey Finnish, welcome back. 🙂 I see you’ve the ‘Resize remote screen’ option enabled, which overwrites the size requested by custom resolution setting. Try to disable it and let me know if the resolution is correct.

    #23809
    Avatar
    Finnish
    Participant

    I try to disable ‘resize remote screen’ and i can install custom resolution. But I see “scroll line” bottom and side. And I turn on ‘resize remote screen’ and size window adapts to resolution.

    #23811
    Avatar
    Tor
    Contributor

    Hi. Your monitors are 5120 x 1400 at full size, so in order to avoid scrollbars you should either enter fullscreen mode, or set a custom size matching the size of your window maximized (more or less that 5119 × 1368 of the old post). You could also enable “Resize remote screen” and enter fullscreen: in that way you don’t even need to set the custom resolution because the client will automatically use 5120 x 1400.

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.