Maximum resolution – dual monitor

Forums / NoMachine for Windows / Maximum resolution – dual monitor

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #27885
    AvatarRanger4564
    Participant

    I’m using the latest Ubuntu (16.04 64bit)  and Windows (7 64bit) stable 6.10.12.1 builds.

    Windows has the Windows 8 RDP update to enable resolution above 4096 or whatever the original limit was.

    I have nearly identical hardware / monitors on both sides – custom built Supermicro X9SRA with Intel 64bit processors,  EVGA GTX 1080 TI at work,  GTX 780 at home, (2) NEC 27″ monitors on both sides.

    Each monitor is 2560 x 1440, so typical resolution on each side is 5120 x 1440.

    When I connect from Ubuntu or Windows 7 at home, to Windows 7 at work, I can only see 1 monitor and maximum resolution is 2560 x 1440.

    How can i get dual screen or at least higher resolution?

    Currently, NoMachine is apparently getting the resolution from one of the monitors, and not the capabilities of the video cards.

    Thank you.

    #27948
    AvatarTor
    Contributor

    Hi. We’re not currently aware of issues with detecting monitors connected to the remote desktop, you should be able to use both monitors at full resolution.
    Can you please open the menu (Ctrl + Alt + 0) and verify if you see the “Change monitor” button in the Display menu? Could you send a screenshot of the Display settings panel, so we’ll know the parameters that are being detected? Thanks.

    #27976
    AvatarRanger4564
    Participant

    Hi Tor,

    Thank you for the response.

    Screen shots below.

    Even though I have 2 monitors at work, and 3 at home, NoMachine only sees 1 monitor at work… which I believe could be Microsoft RDP. But RDP doesn’t limit resolution to 1 monitor’s worth of pixel area, RDP allows me to use 5120 x 1440 if I connect with [removed] or [removed]. [removed] is slower. [removed] doesn’t work well with 2 screens, it’s just a flaw that won’t be fixed.

    What I’m saying is, I can see all of the real estate with other applications when I remote to work, I just can’t get NoMachine to detect either 2 monitors, or to allow the 5120 x 1440 resolution, even if it treats it as 1 monitor. See how Maximum Resolution is 2560 x 1440? And only showing 1 monitor?

    I hope that makes sense. Willing to try options if you have thoughts. I could not find any settings in windows that allow RDP to provide 2 monitors – Multimon, or Span option are really only useful for connecting with RDP to RDP.

    Thank you.

    #27980
    AvatarRanger4564
    Participant

    An update for my question and response.

    This is what Windows shows for remote desktop monitor – it uses a virtual monitor. This I believe is consistent.

    I am trying to get NoMachine to show 2 separate monitors, or 1 large monitor, either is OK for me.

    Thank you.

    #27998
    AvatarTor
    Contributor

    Could you please clarify if the screenshot of the display settings was taken while NoMachine was connected to the desktop? I see you often talk about RDP, but I didn’t understand if you do it as a comparison or to outline that you’re connecting to the desktop while an RDP connection is active. Thank you.

    #28002
    AvatarRanger4564
    Participant

    Yes, the screenshot was connected to the remote pc when I took that screen shot.

    I am not connecting with more than 1 software at the same time – the PC is set to only allow 1 remote connection at a time.

    Something happened, I’m not troubled to figure out what, but [removed] no longer connects properly, it is erroring out because of our DUO 2 factor authentication setup. It didn’t have any issues before today, but it’s freaking out today.

    [removed], which i use every day, connects to RDP no problem. Screenshot attached.

    NoMachine connects to RDP no problem, but it does not honor the DUO 2 factor authentication feature. Screenshot attached.

    The screenshots show Windows Display Manager under [removed] vs NoMachine remote connection.

    Thank you.

    #28005
    AvatarRanger4564
    Participant

    To clarify, the post 27980 from June 5 at 7:11, shows the windows display manager, while I was connected through [removed].

    Reply from today should clarify, but I just wanted to correct my statement in my reply.

    When I connect with [removed] Windows sees the monitor as a virtual monitor and capable of 5120 x 1440 (resolution of my connection, not a limit of the video card).

    When I connect with NoMachine, Windows see the monitor as the physical monitor, monitor 1 which is an NEC EA275WMi. That monitor’s native resolution is 2560 x 1440, which is what NoMachine is allowing me to use.

    Hope that all makes sense.

    #28039
    AvatarTor
    Contributor

    Hey Ranger, thank you for sending the useful information. There are many differences between NoMachine and Windows Terminal Services, and one of those is for sure the way they deal with displays on the server. When you connect with RDP, Windows Terminal Service creates a desktop with virtual displays that don’t necessarily match the actual monitors connected to the server (usually RDP clients allow to use the default display resolution or set a custom resolution). In your recent screenshot I see your machine lists a single monitor NEC 2560×1440, which is the one shown in NoMachine display settings. In order to see correctly two monitors in NoMachine you need to verify why your PC at work doesn’t show both NEC monitors in display settings.

    #28043
    AvatarRanger4564
    Participant

    Thanks Tor. That’s the problem and basis of my original question.

    I imagine Windows only allows 1 display in remote sessions. The virtual display.

    But I can’t tell if NoMachine is actually using portions of the RDP protocol which would limit it to 1 monitor, or not.

    Are you able to see more than 1 monitor, or are you only using 1 monitor in your setup?

    I need to find out how NoMachine is selecting monitors in the remote session. If it’s relying on windows RDP, then it may be a setting in a configuration file? Don’t know yet.

     

    #28044
    AvatarRanger4564
    Participant

    Just to clarify, my PC at work shows both monitors properly when I’m at the desk.

    It’s only 1 monitor when it’s a remote session. With RDP / [removed] / [removed], they use the virtual display. With NoMachine, it’s using the physical display but I don’t know why it’s not showing both displays.

    #28066
    AvatarTor
    Contributor

    But I can’t tell if NoMachine is actually using portions of the RDP protocol which would limit it to 1 monitor, or not.

    The free version of NoMachine doesn’t support RDP sessions, it’s a feature available in the Linux Terminal Server products.

    Are you able to see more than 1 monitor, or are you only using 1 monitor in your setup?

    If you can correctly connect to the Windows physical desktop (the same you use at work) and both monitors are detected by the Operating System (they’re not switched off/disconnected), you’ll see all your monitors in the remote desktop session of NoMachine and you don’t need to virtualize your desktop like you’re used to do with RDP.

    #28089
    AvatarRanger4564
    Participant

    Tor,

    Thank you.

    I want to confirm the issue I brought up in this thread was resolved by having both monitors powered on.

    Once they were both on, NoMachine was able to see both, and allowed me the options I expected, and I can use each or both monitors to remote to the work machine.

    It would be nice if there was a config page that allowed me to tell NoMachine there are 2 monitors, or that the video card can handle the resolution, so the monitors would not need to remain in powered on mode… but this will work for my testing purposes.

    Thank you for your help Tor.

    #28094
    AvatarTor
    Contributor

    I’m happy you solved it. 🙂 I’ll forward your request to devs, so they can evaluate it.
    By the way since the video card is responsible for notifying the number of connected monitors, you could check if there is a setting allowing to report the monitor as connected also when it’s turned off. You could also configure energy saving settings, it’s not like turning the monitor completely off but it’s better than leaving it switched on.
    Lastly, if you want to hide what you’re doing while you’re connected to the desktop for privacy reasons, you can enable the display blanking option in server settings.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.