Microphone plays all the time and hears sound from the speakers

Forums / NoMachine for Windows / Microphone plays all the time and hears sound from the speakers

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #26657
    Avatarpusyakaryagin
    Participant

    Hello.
    I use NoMachine to connect a thin client with a virtual operating system.
    The client plays sound from the remote system and normally transfers the microphone. However, if some application (like Skype) uses a microphone, then two things happen:
    1) the client begins to play the sound from the microphone into the speakers, and without headphones it causes scary sound effects
    2) the application that listens to the microphone (for example, the person in Skype) starts to hear all the local sound (background music, his voice)

    Client: lenovo s10-2 laptop with Lubuntu 18.04 (LXDE), it fully works when connect to physical Ubuntu machine (mic works normally)

    Remote machine: Windows 10 1809 ltsc on a Virtualbox (v6.1.4). Host has Ubuntu 18.04 (Gnome) and direct connect to it works well without that mic issue.

    NoMachine free latest version both (6.9.2-1), but tried 6.6 too.

    What did I do:
    installed windows updates;
    instaled the previous version of !M;
    set up different sound adapters in Virtualbox, and even tried with no sound adapter.

    I noticed that with the emulated Intel HD audio adapter, the reproduced sound on the client starts to play intermittently, and the microphone stops working at all.
    If I disconnect all sound adapters or use AC97, then the same behavior is observed, as described above.
    Other types of connections (RDP) do not contain this problem, but they do not suit me.
    #26870
    Avatarwitek
    Participant

    Hi,

    We need to ask you some questions to investigate the problem.

    1. What is your default input/output device on the Windows system?

    2. What do your Skype audio settings look like?

    3. Do you use Skype as a desktop application or do you use it via Chrome for example?

    4. This Skype application is already running before you connect with NoMachine?

    5. Have you changed any audio settings on Windows or did you just leave it as it is by default?

    #26883
    Avatarpusyakaryagin
    Participant

    Hi,

    Temporarily solved the problem by giving the user access to a virtual machine with Linux instead of Windows.
    Probably, in my case, the problem is related to the Windows system itself. Because when I open the sound settings in the control panel, the system shows a blue screen.
    I answer nevertheless:

    1. As a sound output, “NoMachine microphone adapter” is selected by default. Like the sound input is the same.

    2. “Default communications device” selected in Skype

    3. Using Skype as desktop app (not from Store)

    4. Yes. I tried to restart it after the connection, without a positive result.

    5. First I left it as it was, then I tried to activate other sound outputs. It had no effect.

    I note that the problem is observed in any applications that receive sound from a microphone. I tried Firefox, Skype and Audacity.

    Thank you for help.

    #27044
    Avatarwitek
    Participant

    Hi,

    Sorry for the late response. Yes, the problem is related to the Windows system.

    when I open the sound settings in the control panel, the system shows a blue screen.

    Did you see what caused this BSOD? Could you send us mini dump file generated by the operating system? You can find it in %SystemRoot%\minidump directory (by default it should be C:\Windows\minidump). Please send it to forum[at]nomachine[dot]com using the title of that forum’s thread as the mail’s subject.

    1. As a sound output, “NoMachine microphone adapter” is selected by default. Like the sound input is the same.

    “NoMachine microphone adapter” should not be set as a default output device when you want to use microphone.

    <cite>5. First I left it as it was, then I tried to activate other sound outputs. It had no effect.</cite>

    Did you try to do this before you connect with NoMachine? If not, please set the default output device to something different than “NoMachine microphone adapter” and then connect to the server via NoMachine. Leave default input device  as it is (“NoMachine microphone adapter”).

    /witek

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.