Micro-stutters with high cpu usage

Forums / NoMachine for Windows / Micro-stutters with high cpu usage

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #17160
    LordCorvin
    Participant

    Hey, not sure if anyone else had this problem.

    Currently testing out xeon5506 server with rx550 as the gpu. Have constant micro-stutters every 1-3 seconds. Noticed that cpu spikes a lot. Is it due to cpu not able to keep up with encoding of the screen? No noticeable difference if I change resolution though. Running at 1280×768 res. Is there a way to check if NoMachine server is actually using cpu or gpu for video encoding?

    Thanks for your time,

    LordCorvin

    #17175
    graywolf
    Moderator

    Check the session files in /usr/NX/var/log/node/C-*:

    grep -i encod /usr/NX/var/log/node/C-*/session

    If you get:

    Info: Using H.264 software encoder.

    the encoding is done by the CPU, otherwise you’ll get “hardware encoder” if it is done by the GPU.

    #17178
    LordCorvin
    Participant

    Sorry, forgot to mention that I’m using NoMachine Server for Windows

    Any such files on Windows version?

    Thanks

    #17191
    graywolf
    Moderator

    Search the folder %ProgramData%\NoMachine\var\log\node\

    #17227
    LordCorvin
    Participant

    Found the Log. Apparently It can’t load the H.264 library. Any idea why?

    NXAGENT – Version 6.0.66

     

    Copyright (C) 2001, 2016 NoMachine.

    See http://www.nomachine.com/ for more information.

     

    Session: Starting session at Fri Jan 19 20:55:04 2018.

    Info: Agent running with pid 708.

    Info: Slave server running with pid 3632.

    Info: Listening to slave connections on port 12001.

    Info: Display running with pid 8684.

    Info: Audio server started with pid 2936.

    Info: Audio client started with pid 5636.

    Info: Display server started with pid 7244.

    708 8684 20:55:04 500.312 AudioSystemUtilities: WARNING! Could not request  original voice card name.

    Session: Session started at Fri Jan 19 20:55:04 2018.

    708 8684 20:55:06 296.415 AudioSystemUtilities: WARNING! Could not request  original voice card name.

    Warning: Can’t load H.264 codec library.

    Warning: Child process 1396 exited with code 2, ‘No such file or directory’.

    Info: Events handler running with pid 1092.

    Info: Using SSE3 for screen analysis.

    Info: Screen capture running with pid 6788.

    Info: Using display polling for screen updates.

    Info: Using screen size 1280×768.

    Info: Screen analysis running with pid 3484.

    Info: Using desktop manager for screen updates.

    Info: Using DirectX for screen updates.

    Info: RT handler running with pid 6352.

    Info: Display server for 3F143A6617976D10126AB53146E15873 connected on Fri Jan 19 20:55:08 2018.

    Info: Audio server for 3F143A6617976D10126AB53146E15873 connected on Fri Jan 19 20:55:08 2018.

    Info: Audio client for 3F143A6617976D10126AB53146E15873 connected on Fri Jan 19 20:55:08 2018.

    708 4564 20:55:08 319.531 AudioIoWasapiClientDevice: Cannot activate client.

    708 4564 20:55:08 319.531 AudioIoWasapiClientDevice: Error is AUDCLNT_E_DEVICE_INVALIDATED.

    Info: Using Vp8 software encoder.

    708 6788 20:55:08 378.534 GPUEngine: Configuring GPU resources.

    708 6788 20:57:43 395.401 MediaRealtime/Realtime: WARNING! Write to FD#2024 would block.

     

    #17277
    graywolf
    Moderator

    Hardware encoding seems unavailable and you haven’t got a software encoder. See https://www.nomachine.com/AR10K00706

    #17286
    LordCorvin
    Participant

    It says: NoMachine supports H.264 hardware encoding provided by graphics cards with Nvidia Kepler microarchitecture onward.

    Does it mean AMD is unsupported? Chrome detects h.264 acceleration. RX550 specs say h.264 acceleration is supported.

    #17300
    graywolf
    Moderator

    AMD cards provide H.264 encoding but the API is different. NoMachine does not leverage it at the moment but support for AMD encoder is under development.

    #17332
    LordCorvin
    Participant

    That sucks 🙁

    Any approximate ETA on AMD support? Or it’s ready whenever it’s ready? Any beta versions you need testing?

    #17353
    Britgirl
    Keymaster

    It’s planned for version 7. The associated Feature Request is here: https://www.nomachine.com/FR01P03578

    #17367
    LordCorvin
    Participant

    Great!

    Thanks, I’ll keep an eye out for Version 7

Viewing 11 posts - 1 through 11 (of 11 total)

This topic was marked as solved, you can't post.