Mint 21 connection screen closes

Forums / NoMachine for Linux / Mint 21 connection screen closes

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #41890
    il1142
    Participant

    I run 5 pc’s with Mint, one 21 the rest 20.3.  Installed NoMachine 8.2.3 on all boxes. When the Mint 21 box tries to connect to the others, it seems to do so then quickly the window dims and closes the screen.  This is only happening to the Mint 21 box trying to connect to any of the others.  The other boxes connecting to the others, and mint 21 box, work as intended.

    I see other similar issues posted in the past with various causes, but have not found a solution yet.   It does core dump, attached, and is related to nxplayer.bin.  Tried completely removing and reinstalling to no avail.

    Any thoughts?

    Thx,  Ron

    #41899
    Britgirl
    Participant

    Hi, can you send the attachment to us directly at forum[at]nomachine[dot]com? Thanks.

    #41903
    il1142
    Participant

    sent 😉

    #41921
    Wibbling
    Participant

    I appreciate it’s not especially helpful, but I am also having this issue. The viewing device is Mac OS and the server is Linux Mint 21. On both sides, Nomachine 8.2.3.

    The connection being ‘dropped’ is a bit of a pain, but more disconcerting after logging back in to the server from the viewing device (the Mac) anything running on the server is stopped. I’ve tried the workaround of editing node.cfg here: https://forums.nomachine.com/topic/session-terminated-unexpectedly.

    Please do let me know if I can be of any assistance in diagnostics. One bit that might help is the error ‘connection limit reached’ – yet I’m the only device connected. Please let me know how to provide a useful log file and I’ll sort that out.  Thank you!

    #41944
    Britgirl
    Participant

    Could you both try disabling hardware decoding on the Player side? You can do this by editing the player.cfg file on the affected Mint client machine.

    <option key=”Enable hardware accelerated decoding” value=”disabled” />

    On Linux the player.cfg file is created in the user’s home/.nx/config directory: $HOME/.nx/config/player.cfg

    #41946
    il1142
    Participant

    Hi Brit!   Already did that as suggested in another thread with no luck!

    #41955
    il1142
    Participant

    Hey Britgirl,

    More info for ya.  I completely removed 8.2.3 from the Mint 21 box, rebooted, then installed 7.9.2 that I had.  Low and behold, works as it should and I’m able to get to all the boxes.   So I do an update to 8.3.2 from the app, restart, and she’s back to where I was, the mint 21 box won’t connect and just closes the windows again.  It did do another core dump and it looks the same as I had sent ya!

    #41972
    Britgirl
    Participant

    The core dump you sent indicates a problem with hardware decoding on the machine you are connecting from. So the problem is there.

    Make sure you:

    1. Quit the Player (systray icon, right click, ‘Quit NoMachine player’)
    2. Then disable hardware decoding on in the player.cfg -> option key=”Enable hardware accelerated decoding” value=”disabled”.
    3. Restart the Player.
    4. Try connecting again.

    #41983
    il1142
    Participant

    That did the trick Britgirl!   I had previously changed that setting in the app, which didn’t work.  Editing the cfg file directly worked!!

    Thank you much, great app you folks produced!!!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.