Missing audio activity from NoMachine client

Forums / NoMachine for Linux / Missing audio activity from NoMachine client

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #27774
    Avatarsicp_2020
    Participant

    I’ve been troubleshooting an issue where NoMachine does not output any audio it’s receiving from the host machine on Ubuntu 18.04.4.

    I am remoting from Ubuntu into a mac running Catalina 10.15.4, and confirmed that all permissions are correct on the host side since I can see nxnode and the whole NoMachine app in the Privacy > Accessibility Menu (picture attached). The output device is also set to “NoMachine Audio Adapter”.

    Given this, and the fact that running:

    pactl list sources | grep nx

    or:

    pactl list sources | grep NoMachine

    in a linus terminal yields no results. I believe the issue is client-side with Ubuntu (or pulse audio) not receiving anything from the NoMachine application. I’ve also tried to kill pulse audio and restart NoMachine as instructed here with no results: https://www.nomachine.com/AR10Q01048

    Can someone give any advice on how to fix this?

     

    #27839
    Avatarwitek
    Participant

    Hi,

    NoMachine on the client side on the Linux system is not creating any source or sink so because of that
    you will get no result from these commands. NoMachine application should use default sound output (headphones, speakers etc.). If you are able to hear some audio from other applications I will suggest to leave it for now and focus on MacOS.

    1. Do you use NoMachine 6.10.12 on this mac 10.15?

    2. When you connect to the mac 10.15 for the first time via NoMachine
    you should get request which reports that “NoMachine” would like to
    access the microphone. Did you get it?

    3. Please can you open Settings -> Security & Privacy -> Privacy -> Microphone panel and check if
    “NoMachine” is available there (like on the attached screenshot)?

    #27951
    Avatarsicp_2020
    Participant

    Thanks witek!

    1. Yes, I am using the latest version of NoMachine on this Mac.
    2. I just reinstalled NoMachine and did not see it request microphone access at any point, it only asks to enable permissions under “accessibility” as pictured above.
    3. I do not see the NoMachine app under microphone permissions, is there a way in which I can force the app to request microphone permission? Also, is this the reason why no audio is being streamed from the mac?

    Thank you.

    #28208
    AvatarBritgirl
    Keymaster

    Can you update to the latest version we released earlier this week? NoMachine 6.11.2. The following TR was fixed in that release which is probably what you were encountering.

    Audio is not working when NoMachine v. 6.10.12 is installed on macOS Catalina
    https://www.nomachine.com/TR05R09720

    #28222
    Avatarsicp_2020
    Participant

    Great! Upgrading to NoMachine 6.11.12 on MacOS 10.5 definitely fixed the issue. Thank you for letting me know this was released!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.