Mod keys not working in Parallels VM

Forums / NoMachine for Mac / Mod keys not working in Parallels VM

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #12264
    Guest
    Participant

    https://www.nomachine.com/TR04L04386

    It seems either this is a regression of the above link or it as not actually fixed. Both of my machines are running the latest version 5.1.44

    #12275
    Guest
    Participant

    I have also tried the “work-arounds” by defining shift-shift, ctrl-crtl, etc keyboard shortcuts and by setting VM to use keyboard for games, neither of these resolve the issue.

    #12285
    graywolf
    Moderator

    Can you try DisplayServerExtraOptions "-oldeventapi 0" in /usr/NX/etc/node.cfg? Restart server after changes.

    #12308
    Anonymous
    Inactive

    I encountered this problem, from a Windows display client, to an ‘El Capitan’ MacOS 10.11.6 NX server (5.1.44) with a Parallels 11.2.1 Ubuntu 16.04 VM.

    When I was accessing the VM window on the MacOS server, from the Windows NXplayer (5.1.44), it would not recognized the meta keys (mod keys) and only type lower case with no control signals. If I worked directly at the MacOS display and keyboard, the meta/mod keys worked correctly.

    The work-around (indicated previously): edit (in MacOS)
    /Applications/NoMachine.app/Contents/Frameworks/etc/node.cfg
    uncomment or create a new line
    DisplayServerExtraOptions ¬†“-oldeventapi 0”
    Then restart the NX service (or reboot)

    I’m pretty sure this had been working correctly, earlier in the year, but broke at some point in the last few months.
    The release notes say it’s fixed in 5.1.40¬†https://www.nomachine.com/SU07N00101&sn=TR04L04386
    However, that does not seem correct for 5.1.44

    It looks to me like this is a problem which keeps coming back.

    #12309
    Anonymous
    Inactive

    I should add that setting

    DisplayServerExtraOptions “-oldeventapi 0”

    in the node.cfg file does get the meta keys working, but has the side effect of making inhibiting the cursor from reappearing after typing, without a bunch of mouse shaking and right clicking. It’s not a hassle free work-around.

    #12324
    Guest
    Participant

    Adding the DisplayServerExtraOptions does seem to work with my initial testing, thanks guys!

     

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.