Monitor cannot be started for session type loginwindow

Forums / NoMachine for Linux / Monitor cannot be started for session type loginwindow

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #31178
    Avatarcybermartini
    Participant

    I’m using a fresh install of Ubuntu 20.04 Desktop with NoMachine 7.0.211 free edition.  The Ubuntu install is default so it is using gdm3/GNOME as the display manager.  This is also a Ubuntu virtual machine running on an ESXi server so there is no physical monitor connected.  When Ubuntu is at the login screen (from a reboot) and I try connecting with NoMachine (using the 7.0.211 Mac client) the nxserver.log shows the following:

    147673 147673 2021-01-07 10:37:21 642.570 NXSERVER WARNING! nxclient –monitor cannot be started for session type loginwindow.

    If I login to the Ubuntu machine locally (using the ESXi console), I can then access it fine using NoMachine until the system reboots again and returns to the login screen.  I leave the Ubuntu machine locked after the initial login which allows NoMachine to connect when I need to access it.

    Is there a way to allow NoMachine to connect to the login screen on Ubuntu 20.04 so that I don’t have to login locally (ESXi console) first?

    #31278
    AvatarMth
    Contributor

    Hello.

    If this is default Ubuntu installation it is possible that even if it has disabled Wayland on desktop, it will still be enabled on Login Window. This may be the issue here as NoMachine
    cannot reliably capture screen on virtual machines that use Wayland by default.

    Please check if the Wayland is enabled on the Login Window.

    If it is enabled please follow the article:

    https://www.nomachine.com/AR04R01083 (“Connecting to a Wayland-based desktop running in a Linux virtual machine”)

    Disabling the Wayland from Login Window is also valid here, as it is not really impacting the system much.

    If it is disabled, NoMachine should be working by default there, so we would require logs from the server machine to investigate this problem further.

    Please follow the article on how to enable debug:

    https://www.nomachine.com/DT10O00163 (“How to gather debug logs for support requests”)

    Then please do:

    sudo /etc/NX/nxserver –restart

    Gather the logs either manually or by executing:

    sudo /etc/NX/nxserver –debug –collect

    Please send the logs to forum[at]nomachine[dot]com using the title of this forum’s thread as the mail’s subject.

    /Mth

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.