Mouse click and move in Logic Pro (High Sierra)

Forums / NoMachine for Mac / Mouse click and move in Logic Pro (High Sierra)

This topic contains 8 replies, has 4 voices, and was last updated by Avatar bucu 1 month, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #23372
    Avatar
    noise
    Participant

    Hi all

    I use NoMachine for remote my Studio with Logic Pro because Apple Remote doesn’t recognize the alt key. But with NoMachine it works… however now I have one problem…

    I can’t click and change the values, like the channel eq values (not in the eq screen itself only values like hz, db and q)

    the same are in transposing (click and move up or down) are not work.

     

    #23389
    Avatar
    graywolf
    Moderator

    Hello, would you send a screenshot showing the elements that does not respond to clicks?

    Would you try to change NoMachine options in file /Applications/NoMachine.app/Contents/Frameworks/etc/node.cfg:

    DisplayServerExtraOptions "-oldeventapi 1"

    Restart NoMachine server after the change. Does it change the behavior?

    #23398
    Avatar
    noise
    Participant

    Thank you for the fast answer, I will try your config and report a.s.a.p.

    Here are two pictures, these values are not controllable via remote click and move

     

    #23401
    Avatar
    noise
    Participant

    /Applications/NoMachine.app/Contents/Frameworks/etc/node.cfg:

    DisplayServerExtraOptions "-oldeventapi 1"

    works perfect (y)

    I think afterwards, an update is needed to replace the node.cfg

    Many thanks (y)

    #23421
    Avatar
    graywolf
    Moderator

    Thanks to let us know. May I we ask you to try a NoMachine package with debug turned on? I’d like to gather more information about this problem.

    #23433
    Avatar
    noise
    Participant

    yes, no problem. I don’t use it every day, but but I can do it 😉

    let me know…

    #23592
    Avatar
    Britgirl
    Keymaster

    @noise please check your email inbox 😉

    #23722
    Avatar
    noise
    Participant

    downloaded, but see i have installed ‘nomachine_6.7.6_6.dmg’

    the download file are ‘nomachine_6.7.6_1.dmg’

    hope this is correct..

    i install now this version at booth side (server/client) and activate the debug loggin, i report you later.

    one thing before i start, it is needed to change these configs ?

    #DisplayServerExtraOptions “-nocomposite -noshpix”

    DisplayServerExtraOptions “-oldeventapi 1”

    #23737
    Avatar
    bucu
    Participant

    Hi,

    please uninstall your current package and install one provided for debug (nomachine_6.7.6_1.dmg). There is no need to modify the cfg files. Just follow the instructions you received via email.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.