Mouse cursor too big on shared screen / remote mouse pointer can’t be turned off

Forums / NoMachine for Mac / Mouse cursor too big on shared screen / remote mouse pointer can’t be turned off

Tagged: , , ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #14593
    hirschferkel
    Participant

    Hi there,

    I switched to NoMachine, as Remote Desktop for Mac is corrupt since version 3.9 and I’m really happy with this alternative, now.

    On thing is actually a little bit irritating: The mouse cursor is un-proportionally big on shared screens and i did not find any setting to adjust this misbehavior. Actually the mouse pointer is sometimes 3 times bigger than the original pointer (regarding the screen resolution e.g. an retina displays from iMacs) on the screen, which one can see while quickly moving the mouse or sometimes when right clicking on the shared screen. I did not find a way to disable the second mouse pointer, which is only hidden, although i turned of the option in the settings, the second mouse pointer did not turn off on 3 different macs.

    The pointer itself looks like a oversized mouse pointer (like the one you get to find the mouse pointer if you don’t know where it is and move the mouse quickly back and forth), but i did not find a way to turn it off and use the original one, too.

    Any idea or help how to get a small mouse pointer and turn off the second one?

     

    Best, Hirschferkel

     

    #14597
    bucu
    Contributor

    Hi,

    the problem you described looks a lot like a situation when you have “grab mouse pointer” selected in the player settings. The big cursor may be caused by the difference between resolution and DPI of the server side and the client one. In order to investigate furter we would need some more info:

    • What is the OSX version you are using on the server side?
    • Is the server side by any chance a headless machine?
    • What is the OS you use as client side?
    • What are the resolutions and DPI used on both server and client side?
    • Does disabling “grab mouse pointer” make the smaller cursor disappear?
    #14599
    hirschferkel
    Participant

    Hi there,

    actually there is no “grab mouse pointer” activated in player settings as you can see in one of the screenshots.

    Serverside is a Mac Pro with a screen resolution of 2 x 27-Zoll (2560 x 1440) and the client side is an iMac with a retina resolution  of 5120 x 2880.

    Both machines use 10.11.6

     

     

     

    #14607
    hirschferkel
    Participant

    Example of Mouse Pointer sizes on one screen with and without NoMachine.

    Attachments:
    #14652
    Britgirl
    Keymaster

    1. Is the additional cursor visible only in the NoMachine session or  is it visible also on the physical Mac Book Pro?

    2. Does it happen in a specific display mode only? (e.g. fit to window, resized)

    3. Can you try to disable stream grabbing on the server side?

    To do that, please set:

    DisplayServerExtraOptions “-nostreamgrab” in node.cfg on server side

    and restart NoMachine:

    /etc/NX/nxserver –restart

    Without this info it’s difficult for us to continue with the investigation.

    #14666
    hirschferkel
    Participant

    1. The double mouse pointer is only visible in NoMachine sessions, it is not even visible in Remote Desktop sessions, but on any device.

    2. The bigger the difference between server side screen resolution and client side screen resolution, the bigger is the mousepointer size difference. The biggest mouse pointer occurs with a session from normal display (Mac Pro not Mac book Pro!) to retina displays like current iMacs.

    3. So i tried to change the node.cfg but there is no influence to this issue with the size on iMac, there is only the oversized cursor left so at least the second mouse pointer is gone there. But on MacMini there is still a second mouse cursor visible.

    #14845
    Britgirl
    Keymaster

    Wrong mouse cursor size on Retina displays
    https://www.nomachine.com/TR05O07752

    Our developers are working in a fix, in the meantime you may register to the TR (‘Notify me when the TR is closed’) to be
    informed when the fix is released.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.