Mute sound not working

Forums / NoMachine for Mac / Mute sound not working

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29383
    AvatarTalix
    Participant

    Hello, I have just started using the free version of NoMachine 6.11.2 on my iMac, and it seems very promising; I’m using it to connect to my iMac from my iPad (NoMachine app version 6.1.9).

    However, the Mute Sound option isn’t working for some reason; while I’m connected my iMac screen blanks correctly, but its sound still plays even though I have “Mute Sound” turned on in the connection settings on the iPad.

    I do not see an option in the iMac’s Server Preferences to always mute the sound; I would expect it next to the “Blank Screen” setting.  Please let me know if I am overlooking it somewhere.

    I am running the latest iOS 13.6.1, and MacOS Mohave 10.14.6.

    Any suggestions you have to fix this issue would be very appreciated.  Thank you for your time and assistance!

    #29386
    AvatarTalix
    Participant

    I found this seemingly-related forum thread belatedly: https://forums.nomachine.com/topic/sound-problem-under-macos-catalina

    I did not know to go to the General tab of the Security and Privacy pane after installation, I only enabled nxnode in the Privacy tab.  There is no prompt on the General tab.

    There is no nxaudio.kext in the /Library/Extensions folder.  As you would therefore expect, when I run the command “sudo kextutil -vvv /Library/Extensions/nxaudio.kext”, I get “No such file or directory”.  When I run the kextload command you provided (“sudo kextload /Library/Extensions/nxaudio.kext”), I get “/Library/Extensions/nxaudio.kext failed to load – (libkern/kext) not found”.

    Is there somewhere from which I can just download the .kext file and then rerun your previous instructions?  Or is there some different path to a fix for MacOS 10.14.6?

    Thank you again for any help!

    #29463
    Avatarwitek
    Participant

    Hi,

    Sound on the server will be not muted if NoMachine audio service does not work properly. In this case it seems that nxaudio kernel extension is not loaded. If you did not approve NoMachine kernel extensions, you can do this by following steps below:

    1. Try to load nxaudio module (the path is different than on MacOS 10.15):

    sudo kextutil -vvv /System/Library/Extensions/nxaudio.kext/

    2. Access System Preferences -> Security&Privacy -> General panel. Click on the “Allow” button (see kext_approval.png).

    3. Check if nxaudio is loaded properly:

    kextstat | grep nxau

    Output of the command above should be similar to

    265 0 0xffffff7f83cd6000 0x5000 0x5000 com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476

    4. Restart NoMachine server using command:

    sudo /etc/NX/nxserver --restart

    If you want to transmit audio from the server to the client, Microphone permission has to be also properly set. When you connect to the iMac for the first time you should get a request that “nxnode would like to access the microphone” (see microphone_request.png). After accepting it, you should be able to see nxnode inside Microphone permission (see microphone_settings.png).

    If audio still does not work, please send us the output of kextutil command (point 1) in your reply.

    #29973
    AvatarTalix
    Participant

    Thank you so much for the straightforward and simple instructions, that immediately fixed the issue (when I eventually had time to try it, haha).  Great customer support! 👍🏻

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.