Muting sound on Windows 10 server mutes sound on client

Forums / NoMachine for Windows / Muting sound on Windows 10 server mutes sound on client

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #37801
    gicory
    Participant

    Hello! I was looking for solution via google, but there was no result. Sorry if I am repeating the issue.
    My problem is I am using Windows 10 Laptop as a server and Windows 10 Desktop as a client. I want to get the sound from my laptop to my PC while laptop will be muted. Mute server button in audio settings just mutes both server and client machines.
    Any thoughts about how can I fix that?
    Thanks in advance!

    #37815
    Britgirl
    Keymaster

    We aren’t able to reproduce this. By default the sound on the server-side is muted and audio is heard within the session.

    Please take a look at https://knowledgebase.nomachine.com/DT10R00167?#6.1 (section on Audio).

    Note that pressing mute (Fig. 17) will mute sound in the session. Is this your case?

    Can you tell me if the checkbox ‘Mute audio on server’ in Fig 18 is ticked or not?

    #37822
    gicory
    Participant

    I need my server (Laptop) to make no sound at all, while client (Desktop) will reproduce the sound. I think it is technically impossible then.

    #37824
    Britgirl
    Keymaster

    The server shouldn’t be making any sound at all whilst someone is connected to it. And from what you write, I understand this is not happening.

    Please, when you’re connected to the server, open the menu with ctrl-alt-session, go to Devices, select Audio and take a screenshot and attach it here. This will show me what I indicated in my previous reply when I referred to the Connection Menu Guide, picture 18.

    Also please tell me the versions of Windows both sides otherwise we won’t be able to investigate.

    #38386
    Britgirl
    Keymaster

    An update to the issue described in this topic:

    Depending on the sound card on the Windows host, it might not be possible to mute audio on the NoMachine server side. If the Windows audio driver doesn’t provide functionalities like ‘mute control’, the WASAPI loopback capture can intercept only silence, when the server is muted.

    Unfortunately there is no way to workaround this behaviour, but it’s possible to install and use the NoMachine Virtual Audio Adapter (NXVAC). On recent Windows versions like Windows 10 and 11, NoMachine installs only the Microphone Adapter, but it’s still possible to install the Audio Adapter manually.

    More details here:
    Muting audio on the server side on Windows 10 and 11
    https://www.nomachine.com/AR04T01159

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.