Nautilus – general protection fault

Forums / NoMachine for Linux / Nautilus – general protection fault

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2127
    dmccully
    Participant

    A rpm was recently updated on my Red Hat Linux 6.5 system and now NX 3 or 4 does not work.

    I also get numerous e-mail about an abrt full crash report when trying to login.

    Anyone else having the same problem?

    nomachine_4.0.370_1_x86_64.rpm is installed.

    Feb 03 22:00:17 Updated: librsvg2-2.26.0-6.el6_5.2.x86_64
    Feb 03 22:00:18 Updated: librsvg2-devel-2.26.0-6.el6_5.2.x86_64

    dmesg indicates:nautilus[34443] general protection ip:30c022633c sp:7fff602653e0 error:0 in librsvg-2.so.2.26.0[30c0200000+37000]
    nautilus[34450] general protection ip:30c022633c sp:7fff1a19ab10 error:0 in librsvg-2.so.2.26.0[30c0200000+37000]

    abrt_version:2.0.8

    cgroup:

    cmdline:nautilus

    executable:/usr/bin/nautilus

    kernel:2.6.32-431.3.1.el6.x86_64

    last_occurrence: 1391535636

    pid:21664

    #2138
    reza
    Moderator

    Not related to NoMachine. It is the same issue for which Red Hat recently released a patch. The package version, which you are using, contains a bug that caused applications using librsvg2 to crash when loading certain SVG images.

    dmesg indicates:nautilus[34443] general protection ip:30c022633c sp:7fff602653e0 error:0 in librsvg-2.so.2.26.0[30c0200000+37000]

    nautilus[34450] general protection ip:30c022633c sp:7fff1a19ab10 error:0 in librsvg-2.so.2.26.0[30c0200000+37000]

    We advise you to patch your system with the latest fix from Red Hat. The advisory they issued was: Updated librsvg2 packages that fix one security issue are now available for Red Hat Enterprise Linux 6.

    If you have a Red Hat subscription, you can get more details here:

    https://rhn.redhat.com/rhn/errata/details/Details.do?eid=25640

    • This reply was modified 7 years, 7 months ago by reza.
Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.