New version of Manjaro GNOME not compatible with NoMachine

Forums / NoMachine for Linux / New version of Manjaro GNOME not compatible with NoMachine

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #38637
    lucasf
    Participant

    Hi there, how are you?

    The new version of Manjaro (2022-05-13) breaks the NX server. This could be due to the new version of GNOME (42.1) or maybe GDM (42.0).

    – Issue: Server refuses connection with 104 error.
    – Partial solution: modify the “/etc/pam.d/nx” file, replacing “su” with “system-login”. On this way, it works, as long as the desktop is unlocked.

    Any ideas how I can fix it?
    Thank you very much!

    Lucas.

    #38647
    fisherman
    Moderator

    Hi,

    Can you tell me if you have problem with lock screen when using physical or virtual desktop?

    #38649
    lucasf
    Participant

    Hi fisherman,

    Yes, of course. I’m using physical desktop.

    Thank you!

    #38654
    fisherman
    Moderator

    if you are using Wayland, can you try to disable it?

    #38655
    lucasf
    Participant

    Indeed, configuring GDM with X11 works fine.

    Now, I have noticed that when the connection is through Wayland (with the session unlocked), a new toggle appears about screen sharing, which in X11 does not appear. Here’s the screenshot (sorry for the Spanish).

     

    Thank you!

    #38658
    Britgirl
    Keymaster

    Please submit the screenshot again, directly to forum[at]nomachine[dot]com or upload using the attach tool (instead of pasting it in the reply 😉 )

    #38659
    lucasf
    Participant

    Sorry, my bad. Here’s the screenshot.

    I can add that I had a little progress with the extension allow-locked-remote-desktop. I think, somehow, the behavior of NoMachine in this new version of Gnome changed.

    Thank you!
    Lucas.

    Attachments:
    #38829
    fisherman
    Moderator

    Hi lucasf,

    Sorry for the delay. Can you explain further what you mean with ‘I had a little progress’? As far as we know, with that extension, everything should work even after logging out from the desktop.

    That said, even without the extension, NoMachine should work by using an alternative method to capture the screen. We found a bug in this method that affects your case and it will be fixed in the next NoMachine version.

    #38834
    lucasf
    Participant

    Hi fisherman, don’t worry.

    Yes, of course. The situation is that I needed to connect to my computer, with the user logged out or even just starting the system. Before Gnome 42.1, I could do it. But now, to “fix” it, I needed the following changes:

    – In “/etc/pam.d/nx”, change “su” to “system-remote-login”
    – Enable Gnome “Allow Locked Remote Desktop” extension
    – Enabling autologin in “/etc/gdm/custom.conf” and then using a script to automatically lock the session.

    This config allows me to connect to my computer in any state.

    Anyway, I’m pretty sure it’s a general problem in Gnome. I think with other remote desktop applications, there are also problems.

    Thank you very much!
    Lucas.

    #38840
    fisherman
    Moderator

    I am glad that you solved the problem.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.