No audio between two Ubuntu 18.04 machines

Forums / NoMachine for Linux / No audio between two Ubuntu 18.04 machines

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • #33388
    AvatarDANZI
    Participant

    Hello,

    I have two Ubuntu 18.04 GNOME machines running v 7.4.1-1.

    There is no audio received by the remote machine (one sound card) from the server machine. The server machine has three sound cards.

    If the remote machine logs into a Win 10 machine, there is audio received. This server has two sound cards.

    In all three machines “stream audio” is checked.

    Any help would be appreciated.

    Thanks, Dan

     

    #33416
    Avatartsotne
    Participant

    Hello,
    1. Have you checked that PulseAudio is working on the server machine?
    (it is installed correctly, users have access to it and it is running, also do you have some modified configuration for it?)

    2. Check if the following /usr/NX/etc/node.cfg keys are set like this:

    AudioInterface pulseaudio
    CommandStartPulseAudio "/usr/bin/pulseaudio --high-priority=no"

    3. When you connect to that Linux machine run this command:
    pactl list > all_list1.log

    4. When you connect and if you had checked “mute server audio” option when connecting to the machine, let’s uncheck it from context menu and run again:
    pactl list > all_list2.log

    5. You can find the instructions on how to collect server side logs here: https://knowledgebase.nomachine.com/DT11R00182

    5. Upload all_list1.log, all_list2.log, server-side logs.

    #33421
    AvatarDANZI
    Participant

    Many thanks for the reply!

    1- yes it is running, pactl list provides much information.

    2-yes set as shown

    3-do I run this command from remote or server?

    4,5 -on hold pending #3

     

    Thanks DAN

     

    #33427
    Avatartsotne
    Participant

    Hi again,
    client side is from where you connect and server where you connect from client. We need server side info. Do I get it right that, when you connect from same client to Windows you get audio but not when you connect to Ubuntu?

    Also can you confirm that pulseaudio path is /usr/bin/pulseaudio on your system (on server) too?

    #33435
    AvatarDANZI
    Participant

    Yes when I log into server I have no audio on the remote. Also the audio on the the server mutes.

    yes I confirmed server pulseaudio is running, and the keys under task 2 are correct.

    I have attached the files from the server as requested. However I was unable to unmute from the GUI, could not find that, I am using v7.4.1. So I unmuted via the volume control of the pc for all_list2. This setting did not give audio on either server or remote.

    Another bit of information, I do not know if it is relevant: the server PC does not have speakers. Audio output is via the LINE-OUT. Under pavucontrol, output devices, built-in-analog stereo, speakers are shown as unavailable, line out is selected.
    The PC is a Dell Optiplex 990 I bought used.

    Thanks DAN

    #33442
    Avatartsotne
    Participant

    Also do test the server that you get audio there (plug in to the Line Out jack)?

    #33441
    Avatartsotne
    Participant

    There is no all_list1.log, all_list2.log files.

    For change muting open context menu, from upper right corner, choose Audio –> Change Settings –> uncheck “mute audio on the server”.

    #33452
    AvatarDANZI
    Participant

    well I sent them!
    Upload Errors:
    all_list1.log: Sorry, this file type is not permitted for security reasons.
    all_list2.log: Sorry, this file type is not permitted for security reasons.

    change permision from root,try again.

    #33456
    AvatarDANZI
    Participant

    “Also do test the server that you get audio there (plug in to the Line Out jack)?”

    That is how the test was run.

    Dan

     

    #33461
    Avatartsotne
    Participant

    Hi again, good to hear that it works and you get audio from it.

    Can you upload all_list1.log, all_list2.log, it’s important to understand what’s happening.

    #33470
    Avatartsotne
    Participant

    Hi again, sorry for the late reply. I just received the email for this comment.

    On the forum there is no file format restriction, if they are big files can you compress them and try to upload them?
    And if you still get upload error you can send them directly to forum[at]nomachine[dot]com making sure to reference the title of the topic as the subject.

    #33472
    AvatarDANZI
    Participant

    Hello,

    To be clear- server has audio out to powered speakers via “line out”, but no audio to remote pc via NM.

    I have twice uploaded the log files, twice they are blocked by your system as security risks.

    I have renamed the logs to .txt.

    DAN

    #33479
    Avatartsotne
    Participant

    Hi again, to get audio on a Linux machine we use PA’s some modules but according to the logs they are not loaded. Just to be sure, did you take it during NM session yes (it will show there only during session)?

    I have to ask to upload logs again.
    On the server machine, run:
    sudo /etc/NX/nxserver --debug --enable all

    Instruction is missing in this part, but for getting all the necessary logs it needs to restart the server:
    sudo /etc/NX/nxserver --restart

    Then connect using NM to that server and collect logs:
    sudo /etc/NX/nxserver --debug --collect

    Upload those logs and while you are connected to the host machine using NM run and copy their output too:

    pactl list sinks short
    pactl list sources short

    #33488
    AvatarDANZI
    Participant

    posted logs

    #33496
    Avatartsotne
    Participant

    Hi Dan,

    The logs are missing, if you still get an upload error you can send them directly to forum[at]nomachine[dot]com making sure to reference the title of the topic as the subject.

Viewing 15 posts - 1 through 15 (of 26 total)

You must be logged in to reply to this topic.