No audio from Linux to Windows

Forums / NoMachine for Linux / No audio from Linux to Windows

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #8901
    ianr
    Participant

    Hi,

    I installed nxserver free 5.0.47 on ArchLinux (lxqt desktop, alsa/pulseaudio sound system) and am connecting from a Windows 10 client with the same version. No sound is streamed. I have enabled debug logging and attached the nxserver.log. The problem seems to start with:

    2015-11-01 18:20:05 181.842  4503 NXNODE   WARNING! Process ‘/bin/pactl load-module module-cli-protocol-unix socket=/usr/NX/var/run/nxdevice/D-1001-7CE711CD9C56564B8C55E1FFA90B26C5/audio/cli.socket’ with pid ‘4812/4812’ finished with exit code 1 after 0,9 seconds.

    2015-11-01 18:20:05 181.931  4503 NXNODE   nxDefaultExitCodeHandler: process with pid 4812 just died with exit code ‘1’.

    2015-11-01 18:20:05 182.046  4503 NXNODE   NXRunCommand: process ‘4812’ exit status was ‘1’

    2015-11-01 18:20:05 182.152  4503 NXNODE   NXRunCommand: process ‘4812’ stderr was ”

    2015-11-01 18:20:05 182.235  4503 NXNODE   NXRunCommand: return: 1

    2015-11-01 18:20:05 182.394  4503 NXNODE   Error while launching ‘/bin/pactl load-module module-cli-protocol-unix socket=/usr/NX/var/run/nxdevice/D-1001-7CE711CD9C56564B8C55E1FFA90B26C5/audio/cli.socket’ command.

    I can’t find any problems with pulseaudio itself. Please help.

    #8921
    Peter76
    Participant

    Hi,

    to help you, we need more information.

    Please reproduce the issue on server side under NoMachine and pulseaudio debug level.

    To do this go to:
    /usr/NX/etc/node.cfg
    /usr/NX/etc/server.cfg

    and change variable:
    SessionLogLevel to 8

    In pulseaudio, change the following in /etc/pulse/daemon.conf:
    log-level=debug

    Logs from pulseaudio will go to /var/log/syslog

    Then restart nxserver, start a new session and collect all logs from nx and
    pulseaudio and put them on forum.

    To retrieve the NoMachine logs, see this guideline:

    How to gather debug logs for Support requests
    https://www.nomachine.com/DT04M00076

    Send to forum[at]nomachine[dot]com.

    Additionally, please collect also all results from these two commands and put them too:
    pulseaudio -v –log-target=stderr

    pacmd
    >>> list-sinks

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.