No audio from MacBook Air to iMac

Forums / NoMachine for Mac / No audio from MacBook Air to iMac

Tagged: , , ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #21115
    Avatarbassralphy
    Participant

    Someone please help!

    I’m connecting to an iMac from a MacBook Air. Both using the free NoMachine version; (current version on both computers is 6.4.6).

    My problem is ‘audio streaming’ is not working. I’ve checked the ‘server preferences’ multiple times to verify the ‘audio streaming’ option is toggled ON, on both computers. I’ve toggled thru all of the audio settings in the actual computers.

    I just simply cannot get audio to pass thru to the client connection.

    Am I doing something wrong? Did I set up the initial connection incorrectly?

    ‘Firewall’ on both Macs are off. The firewall on my router is completely off, and using a Static IP address, but I still did a little bit of port forwarding for safety measures.

    The connection works like a charm, every time. I can control the iMac from my MacBook Air just fine. I can get into all of my programs and even hit ‘play’ in iTunes, Spotify and Ableton; but no audio comes to my MacBook.

    Help please! I’ve already tried TeamViewer with no success. I like NoMachine and I wish it was working!

    Thanks everyone!

    -bassralphy

    #21121
    AvatarBritgirl
    Keymaster

    Hi, Mojave needs you to grant special access to external programs in order to control the Mac from remote as well as access its microphone and camera. (more about this is here if you’re interested: https://www.nomachine.com/AR10P01001)

    It could be that you didn’t enable NoMachine correctly during installation? You should see something like this (see attached image) if you go to your Security & Privacy settings. Check that nxnode and NoMachine programs are in the list and that they are enabled.

    If this doesn’t help, let us know.

    #21137
    Avatarbassralphy
    Participant

    Thank you Britgirl!

    Yeah it’s still not working for me. But since I’ve attempted this remotely from multiple other devices still with no audio, I’m assuming the issue is with the iMac I am trying to connect to. So I’m going to uninstall and reinstall later today to see if that somehow was the issue.

    But nonetheless, I should be able to download the free version package, install it, enable the microphone and app in the ‘security and privacy’ settings, and the audio should work right?

    I just want to make sure I’m downloading and installing the correct software, and initially setting it up correctly.

    Also, on the remote iMac that I am attempting to get audio from, what should the ‘output’ be set on? Internal speakers or the NoMachine Audio/Microphone Adapter?

    Thanks for your help! And good day!

    #21148
    Avatarmkub
    Participant

    Hi bassralphy,

    To solve your problem make sure that nxnode is added to Accessibility card in Security & Privacy (see attachment). Audio output on the server should be set to NoMachine Audio Adapter. On the client side you should choose device that you want to use (headphones \ Bluetooth device \ speakers).

    If the solution above doesn’t work, try to uncheck nxnode app – reboot machine – check nxnode again. If this also did not help, you can add whole NoMachine application to Accessibility.

    Let us know if you have further problems.

    Thanks
    mkub

    #21176
    Avatarbassralphy
    Participant

    I’m all good now! Yay!

    For whatever reason during the installation on the remote computer, it didn’t pull in the correct ‘nxnode’ mod into the security and privacy section. There was an ‘nxnode’ in there and it was checked, but it didn’t look like the one in the forum you notated in your post.

    I had to manually open the files of my NoMachine software, go thru and find the real ‘nxnode’ file, put it on my desktop, then go back and manually add it into the security and privacy section, then ‘check’ it.

    After I did that the audio worked immediately!

    Thanks for all your help Britgirl!

    Good day to you all! I’ve enjoyed NoMachine thus far!

    #21231
    AvatarBritgirl
    Keymaster

    😉 Pleased to hear it’s all working now.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.