No audio on MacOS 10.13.6

Forums / NoMachine for Mac / No audio on MacOS 10.13.6

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #27096
    Avatarnightshade
    Participant

    Audio on one of our machines was playing back on the remote side perfectly until today. No changes were made. We have 10 other machines with the same config and audio is functioning properly.

    Versions:

    • NoMachine v.6.9.2
    • macOS 10.13.6

    Notes:

    • We cannot upgrade the OS past 10.13 at this time for software compatibility reasons.

    Fixes I’ve tried:

    • Uninstalled and reinstalled NoMachine
    • Reinstalled OS — no data wipe, only a reinstall
    • Confirmed audio driver is loaded by running: kextstat | grep nxau
    • Forced reloading the driver: kextutil /System/Library/Extensions/nxaudio.kext

    Referenced Articles (most dont apply since I’m running macOS 10.13.6):

    #27111
    Avatarwitek
    Participant

    Hi,

    We will need logs to investigate the problem.

    1. Please collect NoMachine logs from this macOS 10.13. How to do this you can find here:

    https://www.nomachine.com/DT10O00163

    2. After that run the following command to gather system logs:

    cat /var/log/system.log | grep -e nxnode -e nxau >> nxsystem.log

    Please send NoMachine logs and nxsystem.log file to forum[at]nomachine[dot]com using the title of
    that forum’s thread as the mail’s subject.

    #27188
    Avatarnightshade
    Participant

    Logs sent!

    #27955
    AvatarBritgirl
    Keymaster

    We received the logs. We need you to test whether Apple Audio Core is working properly.

    You can do this by trying to record audio by using another application, for example QuickTime Player:

    1. Connect to this mac via NoMachine.

    2. Play some audio (music for example).

    3. Run “QuickTime Player” and choose File -> New Audio Recording.

    4. In the recorder, click the Options pop-up menu and select “NoMachine Audio Adapter”.

    5. Now you should see volume slider moving around (while playing some audio).

    6. Try to record audio for a few seconds, save it as a file and then play it on a different machine.

    Let us know result of this test. Are you able to here audio of the recorded file?

    #28400
    AvatarBritgirl
    Keymaster

    Further investigation of this issue has allowed the following Trouble Report to be opened:

    Audio is muted in NoMachine sessions connected to a macOS
    https://www.nomachine.com/TR06R09774

    #28405
    Avatarejinla
    Participant

    I was running NoMachine flawlessly on 10.14 for months and then lost audio.  After much trial and error, I found that for some reason the audio in the Macs “Audio Midi Setup” zeros out.   Be sure to check the levels for the NoMachine Audio adapter for both INPUT and OUTPUT.

    #28418
    AvatarBritgirl
    Keymaster

    Indeed, there is a workaround in the Trouble Report which mentions this:

    No sound is coming through NoMachine Audio Adapter, when playing audio inside the NoMachine session. This problem has been reproduced on macOS 10.13, 10.14 and 10.15.

    “This issue is triggered by the fact that NoMachine Audio Adapter is muted. This is not always visible in system sound settings.

    Sometimes in the Audio MIDI Setup, volume stream is set to 0 and it’s enough to raise it.

    In other cases, volume stream in Audio MIDI Setup seems to be already enabled. As a workaround, go through all volume sliders for Input and Output side and lower volume value to 0.0. Then set it again to 1.0.”

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.