No audio – RasPi 3 to Windows remote

Forums / NoMachine for Linux / No audio – RasPi 3 to Windows remote

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #13117
    Avatarjefft
    Participant

    Hi,

    I decided to try NoMachine and it seems to be working very well windows-to-windows and for most purposes on the Pi3 (Debian Jessie) vs a Windows 10 remote.  However, I can’t get sound on the Pi.  The Win10 machine shows the volume muted initially for a device “NoMachine microphone adapter”; whether this is muted or at full volume makes no difference to the lack of sound on the Pi.

    I’ve tried the built-in analogue audio, HDMI audio and a USB (C108) sound device.  In all cases, I can get alsamixer to configure and aplayer to play stuff to the relevant device but nomachine’s sound settings don’t offer any devices in the drop-down lists for speakers and mic selection and there is no sound.

    I wasn’t sure which linux audio system nomachine uses, but found this recent post – https://www.nomachine.com/forums/topic/raspberry-pi-2-raspbian-jessie-no-usb-audio#post-12276 – and ran the NX sound setup and ensured that pulseaudio was running.  Still no sound, however 🙁

    What can I do to check the sound setup and debug this one?  I’d like the USB device working, ideally – although having the choice of HDMI and USB in the nomachine settings would be even better!

    Thanks,
    Jeff

    #13138
    AvatarBritgirl
    Keymaster

    In your other post you mentioned that you got audio working. Is there anything you want to share here in this topic here, or can I close it?

    #13136
    Avatarjefft
    Participant

    Weird.  Just after I posted this, I thought I’d give it one more try.  Ran pulseaudio in the foreground as the user before going anywhere near NM… and lo and behold, I have sound!  I guess perhaps I’d previously only disconnected NM before running pulse, rather than starting pulse first before opening NM.  I’ve also ascertained that it doesn’t like pulse running in system mode, unfortunately.

    So for a dedicated NoMachine thin client, I guess I have to script X windows startup to run pulse and then NM.  Next task… 😉

    #13142
    Avatarjefft
    Participant

    Ah.  I thought I’d added a comment to this one… yes, got it working, so this one can be closed thanks!

    For anyone reading this later – it doesn’t like pulseaudio in system mode; pulse has to be running as the same user as NM and to be started before opening the NM window (the taskbar component runs automatically and it seems fine for that to run pre-pulse).

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.